If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Forwarding an HTML message with distant images embeds the images (attachements displayed inline)

RESOLVED DUPLICATE of bug 176416

Status

MailNews Core
Attachments
RESOLVED DUPLICATE of bug 176416
14 years ago
9 years ago

People

(Reporter: Olivier Vit (just a reporter), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040208 

I'm surprised that when forwarding a message, it gets altered significantly to
include the content displaying inline as attachement, and thus rising the size
of the message.
Why altering when forwarding ?

Reproducible: Always
Steps to Reproduce:
I received a text/html message from dell, no images embedded in the mail message.
I open the message (allowing display of the images inline)
I forward it to myself
X

Actual Results:  
I received a text/html message from dell, no images embedded in the mail message.
I open the message (allowing display of the images inline)
I forward it to myself
I receive a message with all images attached to e-mail (but displaying properly
inline)



Expected Results:  
Receive the original message embedded into a new one

note : Sending as attachement provides the 'expected' result
(Reporter)

Comment 1

14 years ago
Created attachment 142341 [details]
message received originaly, without images as attachments
(Reporter)

Comment 2

14 years ago
Created attachment 142342 [details]
forwarded message, with images as attachments
(Reporter)

Comment 3

14 years ago
revise summary
Summary: Forwarding an HTML message with distant images embedded the images (attachements displayed inline) → Forwarding an HTML message with distant images embeds the images (attachements displayed inline)

Comment 4

14 years ago
See bug 176416.
(Reporter)

Comment 5

14 years ago
Looks similar apart the initial lookup for a mozilla specific tag on the image
that would prevent this behavior to happen

I fear that JF is considering his answer on the tag as sufficient for closing
this bug, while I don't believe it justifies this behavior, nor makes it acceptable

What is the reason for this behavior ? How is it explained ? is it a side effect
of something else, or is it by design ?
(Reporter)

Comment 6

13 years ago
(In reply to comment #4)
> See bug 176416.

OK, is a variation of this bug, but not really a duplicate
How can we progress on these 2 ?!!!

Is there a way to set "moz-do-not-send=true" somewhere in preferences ? nobody
would edit a received message to add such an attribute on all images

Comment 7

13 years ago
It *is* a duplicate because the conversion of the links happens at the same 
time, same place, same code: when the message is converted to be sent.  It 
doesn't matter whether the "http:" link text was inserted manually or as part of 
a forward; the entire message text is scanned, and links updated, when the 
message is sent.

As for a fix -- there is no way yet to do what you want.  See the discussion at 
bug 132257.

*** This bug has been marked as a duplicate of 176416 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.