If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

Camino Graveyard
Toolbars & Menus
RESOLVED WONTFIX
14 years ago
14 years ago

People

(Reporter: Mac OS X Angel, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040225 Camino/0.7+

Recent builds of Camino suffer from the same problem as Firefox - the design of
the navigation buttons is inconsistent with both the design of Cocoa buttons in
Mac OS X applications, as well as inconsistent with the appearance of other
toolbar buttons.

For example, the Previous/Next/Reload/Stop buttons are uninteresting,
black-and-white arrow-or-cross-surrounded-by-black-square buttons, while the
Manage Bookmarks, New Tab and Send Link buttons are colorful and are not bounded
by a square box. The latter ones are also more consistent with the appearance of
Cocoa applications. Compare the navigation buttons with buttons found in other
Aqua "White" applications, such as Mail, Sherlock, Disk Utility and even
Camino's own Preferences window.

It seems like Camino is trying to copy Safari's navigation buttons, however the
difference is that Safari uses the "Metal" appearance, and like iTunes, Address
Book and other Metal applications, uses simpler widgets so as not to compete
with the metal window appearance. On the Aqua "white" background, these buttons
look boring and inconsistent with the other buttons that can (and are by default
- the Bookmarks button appears on the right of the default toolbar) be added to
the toolbar.

The new Camino (and Firefox) nav buttons do not look more Mac OS X-like than
those previously used, and in fact look more out=of-place because of the
colorful revisions to the other icons, such as those in the Preferences window.
Granted, Camino's are less unattractive than Firefox's (the Stop button is just
awful), but they look just plain wrong.

Reproducible: Always
Steps to Reproduce:
1. Open Camino
2. Click View > Customize Toolbar
3. Drag the Send Link and New Tab icons to the toolbar
4. Click OK

Actual Results:  
Got a toolbar full of buttons with inconsistent appearance.

Expected Results:  
Buttons that look consistent and use actual Mac OS X appearance, suitable for
the rest of the look-and-feel of the application (ie: those nav buttons are only
suitable for the metal look).
(Assignee)

Comment 1

14 years ago
we look like the finder and keynote as well, they use a combo of square buttons
and non-buttons on toolbars.

thanks for your feedback.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.