firefox crashes when I attempt to print this page

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Justin Bronn, Assigned: Blake Ross)

Tracking

({crash, stackwanted})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8

Everytime I attempt to print the URL
(http://www.pgroup.com/products/workpghpf.htm), firebird crashes unexpectedly.

Reproducible: Always
Steps to Reproduce:
1.  Visit URL
2.  Try and print the page.
3.  Watch firefox crash :)

Actual Results:  
The firefox window disappears.

Expected Results:  
Firefox should have printed the page, like it prints others.
(Reporter)

Comment 1

14 years ago
Crashes on both Fedora Core 1, and RedHat 9.

Comment 2

14 years ago
This may be a duplicate of bug 185357.

Comment 3

14 years ago
can you attach a stacktrace using GDB ? Run 'firefox -g' then in "GDB>", type
'run' and whe Firefox has crashed and you're in "GDB>", type 'backtrace'
Keywords: crash, stackwanted

Comment 4

14 years ago
Created attachment 148508 [details]
another page which crashes print preview

I also have found print preview to crash Firefox 0.8

I have found 2 ways to stop it crashing:

1. in the CSS, if you remove the "float:left"  from the .item_details class
(but this is not the layout I'm after!)

2. remove content (!). It seems that it doesn't like a div container spilling
over 2 pages.

thanks
rich

Comment 5

14 years ago
ooh, sorry, that last attachment was from Firefox for Windoze (2000) not Linux -
just spotted that. oops.

Updated

14 years ago
Attachment #148508 - Attachment mime type: text/plain → text/html

Comment 6

14 years ago
do you still crash with Mozilla 1.7rc2 ? If so, please post Talkback Incident ID
for this crash by running "mozilla/components/talkback/talkback"
I cannot repro this using 2004-07-27-08-0.9 (aviary1.0 branch) on fedora 1.
marking w4m, but pls reopen if this occurs with a recent trunk (or branch)
build. thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.