The default bug view has changed. See this FAQ.

Expose StorageStream class to Javascript

RESOLVED FIXED

Status

()

Core
XPCOM
RESOLVED FIXED
13 years ago
3 years ago

People

(Reporter: Nick Sayer, Assigned: timeless)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

1.20 KB, patch
Darin Fisher
: review+
Darin Fisher
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

13 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

In order to be able to do form posting conveniently from Javascript, it would be
helpful to expose the StorageStream object.

Reproducible: Always
Steps to Reproduce:
1. in xpcshell
js> Components.classes['@mozilla.org/storagestream;1']

Actual Results:  
Got nothing


Expected Results:  
@mozilla.org/storagestream;1
(Reporter)

Comment 1

13 years ago
Created attachment 142357 [details] [diff] [review]
Proposed patch

Updated

13 years ago
Assignee: wchang0222 → dougt
Component: NSPR → XPCOM
Product: NSPR → Browser
Version: other → Trunk

Updated

13 years ago
Version: Trunk → 1.0 Branch

Updated

13 years ago
QA Contact: wchang0222 → dougt

Updated

13 years ago
Version: 1.0 Branch → Trunk
(Assignee)

Updated

13 years ago
Attachment #142357 - Flags: review?(dougt)

Comment 2

13 years ago
Comment on attachment 142357 [details] [diff] [review]
Proposed patch

r+sr=darin if you make all the '\'-chars line up :)
Attachment #142357 - Flags: superreview+
Attachment #142357 - Flags: review?(dougt)
Attachment #142357 - Flags: review+
(Assignee)

Updated

13 years ago
Assignee: dougt → nsayer
URL: n/a
(Assignee)

Comment 3

13 years ago
mozilla/xpcom/build/nsXPComInit.cpp 	1.193
mozilla/xpcom/io/nsStorageStream.h 	1.10
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
*** Bug 99338 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

13 years ago
Created attachment 151044 [details] [diff] [review]
missing interface changes
(Assignee)

Updated

13 years ago
Assignee: nsayer → timeless
Attachment #142357 - Attachment is obsolete: true
Status: RESOLVED → ASSIGNED
Resolution: FIXED → ---
(Assignee)

Updated

13 years ago
Attachment #151044 - Flags: superreview?(darin)
Attachment #151044 - Flags: review?(darin)

Comment 6

13 years ago
Comment on attachment 151044 [details] [diff] [review]
missing interface changes

r+sr=darin

though, it'd be nice if maxSize were replaced with segmentCount instead.  that
is the convention followed by newer similar interfaces in necko and xpcom.
Attachment #151044 - Flags: superreview?(darin)
Attachment #151044 - Flags: superreview+
Attachment #151044 - Flags: review?(darin)
Attachment #151044 - Flags: review+

Comment 7

13 years ago
not sure where else to ask this, are there any examples on how to use this
"init" interface?

Updated

13 years ago
Flags: blocking1.7?
(Assignee)

Comment 8

13 years ago
nope, sorry :)
a quick scan seems to indicate that nsMemoryCacheDevice uses init(4096, -1, null).

mozilla/xpcom/io/nsIStorageStream.idl 	1.5
mozilla/xpcom/io/nsStorageStream.h 	1.12
mozilla/xpcom/io/nsStorageStream.cpp 	1.29

sorry about the mess, i totally forgot about the related changes. i just pulled
them from my cvs repository as i ran into them, so they really aren't my changes
(and we made them nearly four months ago).
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED

Comment 9

13 years ago
timeless: we need this on 1.7 branch as well?

Updated

13 years ago
Flags: blocking1.7?
You need to log in before you can comment on or make changes to this bug.