CSS: background-color of select control is not displayed correctly when size attribute is bigger than 1 (only happens on Windows)

RESOLVED DUPLICATE of bug 224974

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 224974
14 years ago
14 years ago

People

(Reporter: Andrés G. Aragoneses, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.6) Gecko/20040207 Firefox/0.8

If we display a select with size=7 and style="background-color: #AAAAAA", for
example, it won't display correctly. I'll attach a testcase.

Note:
1. This bug is not present on Linux.
2. Tested OS's in which the bug is present: Win2K, WinXP (both Mozilla Suite 1.6
and Mozilla FireFox 0.8).
3. This bug is not present on Mozilla 1.4! Perhaps it is a regression.

Reproducible: Always
Steps to Reproduce:
Open the testcase I attach.
Actual Results:  
The first select is grey and the second is white.

Expected Results:  
Both selects should be gray.
(Reporter)

Comment 1

14 years ago
Created attachment 142363 [details]
Main testcase for the bug

*** This bug has been marked as a duplicate of 224974 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.