Identity should use the account preferences instead of the default ones

RESOLVED FIXED

Status

defect
RESOLVED FIXED
15 years ago
11 years ago

People

(Reporter: whimboo, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 2000
Bug Flags:
blocking1.7 -

Firefox Tracking Flags

(Not tracked)

Details

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040219
Mozilla Thunderbird 0.5+ (20040226)

After a new identity for an existing account is created without specifying an
SMTP server the composed mail is actually send over the standard SMTP server.
That shouldn't be. Instead the SMTP server from the POP account, this identity
is assigned, should be used.

user_pref("mail.identity.id101.fullName", "Identity 2");
user_pref("mail.identity.id101.useremail", "foo@foo.com");
...
user_pref("mail.account.account5.identities", "id4,id101");

With this configuration the SMTP server from account 5 is not used instead the
default SMTP server is taken. This is definitely the wrong behavior. For
example: The default SMTP server allows only one hard coded address where
instead the SMTP server from account 5 allows as many addresses as you want. So
you arn't able to send your message because the default SMTP server does not
accept the senders address.

Comment 1

15 years ago
Henrik, with "Instead the SMTP server from the POP account, this identity is
assigned, should be used." you mean the SMTP server from id4 should be used?

I agree that the current behaviour isn't the best and I was bothered by it too.
Now with the multiple identity feature it's relevant. What's if more id's are
attached to one account, say "id4,id17,id20,id21". If id4 don't have an SMTP
server too, should we try all other until one carries a server or we run out of
id's?
(In reply to comment #1)
> Henrik, with "Instead the SMTP server from the POP account, this identity is
> assigned, should be used." you mean the SMTP server from id4 should be used?

Yes, because this identity is assigned to this account. But we have to be
careful because one identity could be assinged to multiple accounts, isn't it?
So we have to to retrieve the account from the selected identitiy before sending
it. 

> Now with the multiple identity feature it's relevant. What's if more id's are
> attached to one account, say "id4,id17,id20,id21". If id4 don't have an SMTP
> server too, should we try all other until one carries a server or we run out of
> id's?

No, definitly not. Thats not the behavior we should change to. If one id doesn't
have a STMP set we have to use the accounts SMTP. We can't move through all
others id's cause they could also be attached to a SMTP which will accept only
the address specified by the id. 

For summary: If one id doesn't have a SMTP, the accounts SMTP have to be used
instead.

Comment 3

15 years ago
> If one id doesn't have a STMP set we have to use the accounts SMTP.

Er, an account doesn't have a SMTP, only identities do.

> We can't move through all others id's cause they could also be attached
> to a SMTP which will accept only the address specified by the id.

Not all other id's, just the id's which are attached to the current account.
Since bug 228597, Mozilla knows the identity and the account with which the
message is composed from the identity drop-down.

With multiple identites per account we shouldn't simply assume, the first id in
the id-list of an account is the full-blown one with a SMTP server.
(In reply to comment #3)
> Er, an account doesn't have a SMTP, only identities do.

Sorry, my fault. Now it's clearer for me. So I think the current behavior is
correct. If we don't set a SMTP for an id we can't use any other SMTP instead of
the default SMTP. The user has to take care when adding an identity to his
account since no UI is avaible.
Very anoying. Still the same with the new UI for identities. I'm not able to
assign a SMTP server for an identity. When sending the default SMTP is used and
sent mail isn't stored within the assigned account sent folder instead it lands
inside local folders. 

When an identity is used we should definetely send this message over the account
SMTP and store it inside the account sent folder.

-> Scott could you take a look on this?
Blocks: 44863
(In reply to comment #5)
> When sending the default SMTP is used and sent mail isn't stored within the
assigned account sent folder instead it lands inside local folders. 

Release Note of 1.7 RC1 says that next preference settings are required.
> user_pref("mail.identity.id#.doBcc", false);
> user_pref("mail.identity.id#.doBccList", "");
> user_pref("mail.identity.id#.draft_folder", "SOME URL YOU DON'T NEED TO CHANGE");
> user_pref("mail.identity.id#.drafts_folder_picker_mode", "0");
> user_pref("mail.identity.id#.encryption_cert_name", "");
> user_pref("mail.identity.id#.encryptionpolicy", 0);
> user_pref("mail.identity.id#.fcc_folder", "SOME URL YOU DON'T NEED TO CHANGE");
> user_pref("mail.identity.id#.fcc_folder_picker_mode", "0");
> user_pref("mail.identity.id#.fullName", "YOUR NAME");
> user_pref("mail.identity.id#.organization", "YOUR ORGANIZATION");
> user_pref("mail.identity.id#.overrideGlobal_Pref", true);
> user_pref("mail.identity.id#.reply_to", "");
> user_pref("mail.identity.id#.sign_mail", false);
> user_pref("mail.identity.id#.signing_cert_name", "");
> user_pref("mail.identity.id#.smtpServer", "smtp1");
> user_pref("mail.identity.id#.stationery_folder", "SOME URL YOU DON'T NEED TO
CHANGE");
> user_pref("mail.identity.id#.tmpl_folder_picker_mode", "0");
> user_pref("mail.identity.id#.useremail", "SOME EMAIL ADDRESS");
> user_pref("mail.identity.id#.valid", true);

Is mail.identity.id#.smtpServer defined as expected?
Are mail.identity.id#.draft_folder, mail.identity.id#.fcc_folder,
mail.identity.id#.stationery_folder defined as expected?
When adding a new identity following entries are added to the pref:

user_pref("mail.identity.id7.attach_signature", false);
user_pref("mail.identity.id7.attach_vcard", false);
user_pref("mail.identity.id7.auto_quote", true);
user_pref("mail.identity.id7.compose_html", false);
user_pref("mail.identity.id7.draft_folder", "mailbox://account/Drafts");
user_pref("mail.identity.id7.escapedVCard", "");
user_pref("mail.identity.id7.fullName", "New Identity");
user_pref("mail.identity.id7.organization", "");
user_pref("mail.identity.id7.reply_on_top", 0);
user_pref("mail.identity.id7.reply_to", "bugzilla@hskupin.info");
user_pref("mail.identity.id7.sig_bottom", true);
user_pref("mail.identity.id7.sig_date", 0);
user_pref("mail.identity.id7.sig_file", "");
user_pref("mail.identity.id7.sig_file-rel", "");
user_pref("mail.identity.id7.stationery_folder",
"mailbox://skupin@account/Templates");
user_pref("mail.identity.id7.useremail", "bugzilla@hskupin.info");
user_pref("mail.identity.id7.valid", true);

Neccessary prefs for using fcc folder and the account specific SMTP aren't
added. That should not be done manually within the prefs.js! We have a user
interface which should add this entries automatically.

Comment 8

15 years ago
Apparently the UI still needs some love.  FCC is ignoring the account FCC that a
particular identity is attached to.  The particular identity instead saves sent
mail to local->fcc_folder.  Definitely not a desired action.  If an identity
doesn't have a specific fcc, it should by default save to the account fcc that
the identity is attached to, and if none exists, don't fcc naturally.
This is a very simple bug. Could it land on 1.7 or is it too late for? Because
TB1.0 will be based on this version it should be fixed IMO. Or should this patch
land on the aviary branch first and will be checked in for Mozilla1.8a2 later?
Flags: blocking1.7?
Updated summary to better reflect the actually wrong behavior when using
multiple identities.
Summary: Identity without a SMTP pref should use the assigned account SMTP instead of the default SMTP server → Identity should use the account preferences instead of the default ones
too late for 1.7
Flags: blocking1.7? → blocking1.7-

Comment 12

15 years ago
At least the fcc_folder topic was fixed by bug 246744.

Comment 13

15 years ago
All the underlying stuff is already in place in prefs.js, so wouldn't a better
summary for this be something like: "Need UI for modifying multiple identity
prefs" ??  It's a shame this won't make it into TB1.0.
The compose_html preference probably needs a UI; at the very least, it should be 
initialized per the setting already applied to the account -- which I guess 
means the setting applied to the default identity for the account.  
See bug 249331.
*** Bug 252641 has been marked as a duplicate of this bug. ***
*** Bug 257434 has been marked as a duplicate of this bug. ***
Before some minutes I added a new identity to my second pop account and noticed
that the missing prefs 'fcc_folder' and 'smtpServer' (see my comment 7) are now
created automatically. So all needed prefs are set after creating a fresh
account. I also checked the selected SMTP server. It is set correctly to the one
which is selected for the default identity of this pop account.

It seems that there was another patch who fixed this a time ago. I mark this bug
as WFM now because I'm sure that all missing prefs are in now. The default
identity contains 19 entries and a new added identity has the the count. 
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 18

15 years ago
Henrik,

Is this resolved in a nightly Mozilla or Thunderbird release?  What did you test?

Thanks!
BR
Sorry, i forgot to say that i'm using a branch build of Thunderbird (version
0.7+ (20040827)). 

I changed my default SMTP and added afterwards a new identity. This identity
contains all needed prefs and the correct SMTP (not the new default SMTP). I
havn't tested a build of SeaMonkey. Sorry, if i was too enthusiastic by closing
this bug. If someone could see this bug with SeaMonkey feel free to reopen. IMO
we should find the bug which contains the patch to be sure where it is fixed.
See bug 246024 and bug 259034 for two early entries in the soon-to-be-long list 
of reasons why the current identity/preference UI is simply insufficient.
The original problem -- the SMTP server not being inherited -- was fixed by the 
patch in bug 246744.

More bugs about the failure of attributes to inherit, or to have an adequate UI:
bug 260805, bug 259618.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Reopened to fix resolution.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED
*** Bug 259034 has been marked as a duplicate of this bug. ***
*** Bug 263911 has been marked as a duplicate of this bug. ***
Bug 262300 is about creating a full UI to manage the variety of per-identity 
settings (it's a Thunderbird bug).
Product: Browser → Seamonkey
*** Bug 235954 has been marked as a duplicate of this bug. ***
*** Bug 272354 has been marked as a duplicate of this bug. ***
*** Bug 230757 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.