Trying to create folder <> on a IMAP server crashes Mozilla

VERIFIED FIXED in M13

Status

P3
major
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: bugzilla, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
If I try to crate a folder in my Inbox called <> my Mozilla crashes:

MOZILLA caused an invalid page fault in
module XPCOM.DLL at 0167:60bd2a05.
Registers:
EAX=00000000 CS=0167 EIP=60bd2a05 EFLGS=00010212
EBX=00000000 SS=016f ESP=0063de04 EBP=0063df0c
ECX=000000a1 DS=016f ESI=01a201d4 FS=443f
EDX=816505d4 ES=016f EDI=01a201d4 GS=0000
Bytes at CS:EIP:
80 38 00 74 08 50 8b ce e8 14 fa ff ff 5e c9 c3
Stack dump:
01a201d0 00000000 0063de90 0063fc0c 7800ef03 7802e248 00000000 00000000 780012d9
00000041 780012c2 00000041 00000000 60b36fdb 00000041 60bc519f

From the dos box:
uri,name in callback = imap://hegetest@fep2.sprawl.dk/INBOX,<>
uri,name = imap://hegetest@fep2.sprawl.dk/INBOX,<>
selectedFolder = [xpconnect wrapped nsIRDFResource]

Using build 2000010908

Updated

19 years ago
Severity: normal → major
QA Contact: lchiang → huang
(Reporter)

Comment 1

19 years ago
This bug is related to:
- http://bugzilla.mozilla.org/show_bug.cgi?id=17681

Updated

19 years ago
Assignee: phil → bienvenu

Comment 2

19 years ago
Reassign to bienvenu. May also be related to bug 14231
(Assignee)

Comment 3

19 years ago
I could not recreate this. Can you attach a protocol log? I can't create a child
of the inbox, but I tried it with another folder, and didn't crash.
(Reporter)

Comment 4

19 years ago
Attached is the protocol log. This time I tried to create not a subfolder of
Inbox but another folder at top level.
(Reporter)

Comment 5

19 years ago
Created attachment 4231 [details]
protocol log
(Assignee)

Comment 6

19 years ago
OK, I'm grasping at straws here. Lisa, can someone in QA try this on win98?

Comment 7

19 years ago
Can I try on WinNT? But it seems that today's commercial build is not good for
test...there was bug#23832 for crashing problem.
(Assignee)

Comment 8

19 years ago
Sure, you can try NT, but I didn't have any problems on NT with a debug or
release build, so I was wondering if perhaps the problem was win98-specific, or
at least not reproducible on NT.

Comment 9

19 years ago
OK. Then I will try on Win98....maybe I need to go back to 01-10-M13 commercial
build. But we still had the bug#23530 for 01-10-M13 commercial build problem. I
know the latest good build is 01-09-09-M13 commercial build. David, which build
you think is better for recreate this problem?
(Assignee)

Comment 10

19 years ago
It shouldn't matter what build you try, as long as you can run. This bug has
been reported for many weeks, so any build you try should have the problem.

Comment 11

19 years ago
In order to avoid the crashes that we had for the latest build, I tried on
Windows 2000-01-09-09-M13 commercila build:
WinNT -- Without this problem,  the "<>" folder can be created successfully.
Win98 -- Crashed when just starting the mail....
I will stick on Win98, and try 1/10 commercila build or today latest build
again.....

Comment 12

19 years ago
Wait! David, I already used the same build  and same platform as the reporter.
I got the crash as the reporter had but just different scenario, I suspect this
is build problem for Win98...not the folder creating problem!!
I cannot get today's talkback report!!

Comment 13

19 years ago
I'll ask Esther to confirm this on her Win98 machine.

Comment 14

19 years ago
Using builds 2000010908 commercial and mozilla on win98, I did not crash when
creating a folder at the top level, or 1st sub level.  I created the folders,
opened them, closed the app, then reopened the app and the folders were still
there and accessible.  I even tried to create a folder in the Inbox (which is
what is stated in the original scenario).  Note: With this build if you have
logged in already the Inbox is disabled when selecting the location for your new
folder, however it is not diabled if you haven't logged in yet and you can
choose this as a location.  I thought possibly this was were the crash could be,
but I didn't crash and no folder was created after typing in my login password.
 So I can't reproduce this crash.  gemal, could you give me the name of the
folder you were trying to create, possibly it has something to do with the
characters in the name.  Also, in your comments on 1/13 about crashing on the
sub folder creation, were you still using the 1/09 build?

Comment 15

19 years ago
So, Esther, do you mean that you can create the "<>" folder without crash on
Win98? I am going to try that again....

Comment 16

19 years ago
OK, using build 2000011211m13 and naming the folder <> I crash.  So I guess
that's the criteria to actually name the folder <>.  David did you use this name
when you tried?

Comment 17

19 years ago
A talkback report was sent in, but it didn't ask for information or my email so
I can't retrieve it.  here is what the windows GPF states:
MOZILLA caused an invalid page fault in module XPCOM.DLL at 0177:60be29da.
Registers:
EAX=00000000 CS=0177 EIP=60be29da EFLGS=00010216
EBX=00000000 SS=017f ESP=0063e0e8 EBP=0063e1f0
ECX=000000a1 DS=017f ESI=02e74c94 FS=0f8f
EDX=818923bc ES=017f EDI=02e74c94 GS=0000
Bytes at CS:EIP:
80 38 00 74 08 50 8b ce e8 14 fa ff ff 5e c9 c3
Stack dump:
02e74c90 00000000 0063e174 0063fc0c 7800ef06 7802e248 00000000 00000000 780012d7
00000041 780012c0 00000041 00000000 60b46fdb 00000041 60bd51f9

Comment 18

19 years ago
Yes. I saw this bug can be reproduced from Esther on 01-12-11-M13 commercial
build. So David, maybe this is specific for Win98 platform's problem since I
cannot recreate this problem on Linux & WinNT, either. I means this "<>" folder
can be created from Linux & WinNT successfully!!
Thanks Esther for updating this bug!!

Comment 19

19 years ago
Another note:  This also happens on a POP account.  I tried this again with
build 2000010908m13 and a POP account.  I could create folder with names other
than <>, but as soon as I tried to use that name I crashed with the same page
fault error.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 20

19 years ago
OK, this is a bug in xpcom's nsFileSpecWin.cpp - _fullpath returns null if you
pass it "<>" on win98, but that code doesn't check for null. If I check for
null, the crash goes away. I have to find out who owns this code and get a
review from him, but after that, I'll check in the fix.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Target Milestone: M13
(Assignee)

Comment 21

19 years ago
fix checked in. If you re-open, please move to m14

Comment 22

19 years ago
Verified on 2000-01-25-20-M13 commercial build.
No crash when trying to create folder <> on a IMAP server now.
Maring as verified!!
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.