can not show username correct if the username use gb2312 and it get from ldap

RESOLVED WONTFIX

Status

()

Bugzilla
User Accounts
RESOLVED WONTFIX
14 years ago
5 years ago

People

(Reporter: liaobin, Assigned: myk)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: 

my user name get from LDAP server, and the showname use chinese, so the 
showname is unicode after get from LDAP, but my bugzilla is set to gb2312.
so the name can not show correct.

must translate unicode to locale langage to show username.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Bugzilla is not currently designed to be able to handle specific charsets of any
time.  See bug 126266 for plans to support this in the future.

Bugzilla will not support GB2312 even after the above is fixed.  All plans
currently are to support only Unicode once we have charset support.

Since setting a character set currently involves a local hack, the code to do
said character conversion is very easy.  It requires Perl 5.8.0 or newer.  Look
on http://search.cpan.org/ for the documentation to the "Encode" module.

It should be a matter of something like:

use Encode;
Encode::from_to($username, "utf8", "gb2312");
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
OS: Windows 2000 → All
Hardware: PC → All
Resolution: --- → WONTFIX
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.