Closed Bug 235791 Opened 16 years ago Closed 16 years ago

Save Page As:Complete does not save @imported CSS files

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 126309

People

(Reporter: richardtallent, Assigned: bugzilla)

Details

User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.6

If a stylesheet referenced in a link in the head of an HTML file contains
@import directives to include more stylesheets, those stylesheets are not saved
with the page. Have not tested if this also happens with embedded styles
(<style/> tags) with @import directives.

Reproducible: Always
Steps to Reproduce:
1. Create CSS files "a.css" and "b.css"
2. Create an HTML file that references external CSS "A".
3. In stylesheet "A", include the line "@import url("b.css")".
4. Go to the file menu, select Save Page As.
5. Choose "Web Page, Complete" as the file type and save the page.
6. Go to the saved directory. Notice that "a.css" is placed in the subfolder of
related fil

Actual Results:  
Stylesheet "a.css" is saved in the subfolder for files relating to the saved
page, but not stylesheet "b.css".

Expected Results:  
The file-saving mechanism should parse CSS to find any @import directives and
include the referenced files as it does the links from the HTML file itself,
preferably with recursion.
I think this is more general, I can confirm that this bug is also present in
Mozilla release 1.6 on Linux.
OS should probably be All, and Product Browser. http://www.hubblesite.org/ is an
example of a page where this happens by I am not allowed to change any of that...
Ah, OK, this is actually a dupe of bug 126309.

*** This bug has been marked as a duplicate of 126309 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.