HoTMetaL Pro 3 DOCTYPE should trigger quirks mode

RESOLVED WONTFIX

Status

()

Core
HTML: Parser
--
minor
RESOLVED WONTFIX
14 years ago
10 years ago

People

(Reporter: Stuart, Assigned: dbaron)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

http://www.american-agency.com/london/rent374.shtml has an old <DOCTYPE>
inserted by HoTMetaL Pro 3 (many years ago) which leads to table corruption.
http://www.american-agency.com/london/rent375.shtml renders correctly. This has
an updated <DOCTYPE>. Both render correctly in IE6 & Opera7.

Could this be FFx too strictly parsing? Is it possible to put the old <DOCTYPE>
DTD to trigger quirks mode or whatever (I'm rapidly getting out of my depth).
There must be thousands of old websites using the old format which would inhibit
the takeup of FFx by their regular users....

Oh and thanks for doing a wonderful job so far... 

Reproducible: Always
Steps to Reproduce:
1. See Details
2.
3.

Actual Results:  
See Details

Expected Results:  
See Details

Updated

14 years ago
Assignee: firefox → nobody
Component: General → Layout
Product: Firefox → Browser
QA Contact: core.layout
Summary: <DOCTYPE> causes table corruption. → <DOCTYPE> causes table corruption.
Version: unspecified → Trunk

Comment 1

14 years ago
See http://www.mozilla.org/docs/web-developer/quirks/doctypes.html

The DOCTYPE from the first URL is not in the list of DOCTYPEs that put Mozilla
into quirks mode, whereas the second one is.  The pages can be easily fixed by
changing the DOCTYPE to trigger Quirks mode, as you discovered.

Maybe the DOCTYPE <!DOCTYPE HTML PUBLIC "-//SoftQuad//DTD HTML 3.2 + extensions
for HoTMetaL PRO 3.0(U) 19961211//EN" "hmpro3.dtd"> should be added to the list
of DOCTYPEs that trigger Quirks mode.

Comment 2

14 years ago
I wanted to confirm this bug, but there was only a "Leave as UNCONFIRMED" option :-(

When <!DOCTYPE ...> is present, Mozilla uses "Standards-compliance" mode, and
(at least) ignores the height option of the table tag!

When <!DOCTYPE ...> not present however, Mozilla uses "Quirks" mode, and just
renders the table height as expected.

This is not a bug in fact, but a strict conformance to the W3 CSS standards, but
i think the comformance should be broken here!

(W3 CSS2 says that when the table contents' height is smaller than the specified
height, the specified one should be ignored... But this leads to people omit the
<!DOCTYPE ...>, and thus breaking their page more, tho it renders correctly at
least)
(Assignee)

Updated

14 years ago
Assignee: nobody → dbaron
Status: UNCONFIRMED → NEW
Component: Layout → HTML: Parser
Ever confirmed: true
Summary: <DOCTYPE> causes table corruption. → HoTMetaL Pro 3 DOCTYPE should trigger quirks mode

Comment 3

10 years ago
I'm going to close this as WONTFIX. As said, this method of making the browser compatible with the web was done in a different era of the web. Nowadays Tech Evangelism should have top priority.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.