Closed Bug 235829 Opened 17 years ago Closed 17 years ago

Download more octets then expected and it ignore the pause/resume

Categories

(Toolkit :: Downloads API, defect)

x86
Linux
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 233047

People

(Reporter: khlkh, Assigned: bugs)

References

()

Details

User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040211 Firefox/0.8

1) By following the link to download the file, the Firefox doesn't stop at
reported file size at about 7M. The download status showing over 9M bytes has
been download  (the remaining time shown in negative value) and the download
still going on.

2) Pause/Resume doesn't work properly. The download continues even you "Paused"
it. Toggle it few times make the thing worse.



Reproducible: Didn't try
Steps to Reproduce:
1.
2.
3.



Expected Results:  
1. Download stop once all bytes are received 
2. Download show stop temporary when pause is selected and continue when resume
is click.
the problem is that the size received is listed as decompressed gz size or
something, and the size expected is compressed gz.
Whiteboard: DUPEME
The .gz issue is a dupe, and I imagine that the Pause/Resume issues on this file
are to do with that bug and the browser getting confused.

*** This bug has been marked as a duplicate of 233047 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
QA Contact: aebrahim
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.