Last Comment Bug 235833 - scroll-wheel not scrolling contents of div with overflow-y: scroll
: scroll-wheel not scrolling contents of div with overflow-y: scroll
Status: VERIFIED DUPLICATE of bug 97283
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Windows Server 2003
: -- minor (vote)
: ---
Assigned To: Blake Ross
:
Mentors:
http://www.jordanautomations.com/moz_...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-27 08:45 PST by Paul Jordan
Modified: 2004-03-09 06:33 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Paul Jordan 2004-02-27 08:45:04 PST
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.6) Gecko/20040206 Firefox/0.8


div.main{

	overflow: auto;
	overflow-y: scroll;
	overflow-x: hidden;
 	height:100px;
	width:100px;
}

This creates a 10x100px box that has a scroll bar in it. when the content
extneds beyond it, a little scroll bar appears in the right side, and itcan be
scrolled up and down. This renders fine in FireFox, but the scoll-mouse does not
scroll the content. I belive FireFox should handle this the same way they do
iframes, so when you have mouseovered the content, the scoll-wheel then works on
that small section.

Reproducible: Always
Steps to Reproduce:
1. Hover over section 1
2. Move mouse wheel

Actual Results:  
3. notice nothing happened.

Expected Results:  
the inerr area should scroll, just like it woud If I used an iframe to full the
content from a separate file.

Netscape 7 and mozilla both had this problem, I recall.
Comment 1 José Jeria 2004-02-27 10:25:53 PST
Mozilla doesnt even support overflow-x/y

About the possibilty to be able to scroll elements with overflow, that is bug
97283. Duping.

*** This bug has been marked as a duplicate of 97283 ***
Comment 2 Henrik Skupin (:whimboo) 2004-03-09 06:33:52 PST
verified.

Note You need to log in before you can comment on or make changes to this bug.