Closed Bug 23588 Opened 25 years ago Closed 25 years ago

Can't delete message if Trash folder subfolder of Inbox on Cyrus IMAP server

Categories

(MailNews Core :: Backend, defect, P3)

x86
Linux
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: rzach, Assigned: jefft)

References

Details

(Whiteboard: [PDT+]verified fix already)

One of my IMAP accounts is set up so that the Trash folder is a subfolder of my
inbox.  The server won't let me create folders which aren't children of the
Inbox (responds with Permission Denied).  On this account, I can't delete
messages, although I can move them to the Trash folder.

I suspect the delete message code only looks for the Trash folder as a top-level
folder.  It works on NS4.7.

Linux build 2000.01.10.08
QA Contact: lchiang → huang
Assignee: phil → bienvenu
Reassign to bienvenu
Assignee: bienvenu → jefft
reassigning to jeff.
Assignee: jefft → bienvenu
Status: NEW → ASSIGNED
Target Milestone: M14
Oh, I guess I'll do this. It's probably a namespace issue or something.
accepting
Adding Cyrus on the summary to specify IMAP server.
Summary: Can't delete message if Trash folder subfolder of Inbox on IMAP server → Can't delete message if Trash folder subfolder of Inbox on Cyrus IMAP server
David & Jeff,

I found the same problem occurred on Microsoft Exchange IMAP server, too.
Can this bug handle MS Exchange as well? If so, then I will just adding MS 
Exchange on this bug's summary.

If not, then I need to log another bug against MS Exchange.

How do you think?
*** Bug 24722 has been marked as a duplicate of this bug. ***
Sorry, I misunderstood this bug.
I thought this bug described "cannot delete messages of the Cyrus Inbox/Trash
subfolder" initially....it's "if", not "of"!!

But I cannot delete the msgs on 4.7, either 
-- 4.7 bug? or server problem?
4.7 bug.
I definitely can 1. delete a message (ie, move to INBOX/Trash by clicking
"Delete Msg") and 2. Empty Trash on my Cyrus IMAP server in 4.7.
Are you sure that you are using the following server which you described on 
bug#23442? 

No. 1 (Trash a subfolder of Inbox)
uclink4.berkeley.edu Execmail IMAP4rev1 (2.1.3/199909291709)

Since I cannot delete msg & Empty Trash from 4.7 , they are gray out on 
4.7....If this is 4.7 bug, then I need to log for 4.7, too.
But why zach didn't see this problem on 4.7??
zach is right. Once you set the "Persaonal namespace" to "Inbox." in 4.7 
everything works like a charm.
Okay, looks like we have more bug to file and more works to be done. We need to 
port over namespace stuff and add new prefs to the imap incoming server.
Depends on: 24740
Yes. Jeff & zach are right!!
After I define the personal Namespace, and it works perfect on 4.7.
And we need to improve IMAP namespace on 5.0!!
My namespace is set to "INBOX." But I don't recall fiddling with it, so it must
have been set to that by the server when I created the account or something.
reassigning to Jeff - I think he's working on this. If not, reassign back to me,
please.
Assignee: bienvenu → jefft
Status: ASSIGNED → NEW
Nominating as beta1 stopper
Keywords: beta1
Putting on the PDT+ radar for beta1.
Whiteboard: [PDT+]
I have a fix for bug 24667, bug 22349, bug 23588, & bug 24715. I'll check in 
once I got a review. To test you need to remove the following namespace entries 
for your Cyrus server:

user_pref("mail.server.server5.namespace.other_users", "");
user_pref("mail.server.server5.namespace.public", "");

and add/modify the following entry:

user_pref("mail.server.server5.namespace.personal", "Inbox.");

Unfortunately, we don't have UI for it now.
Fix checked in. 
Status: NEW → RESOLVED
Closed: 25 years ago
Resolution: --- → FIXED
Jeff, 

I thought delete msgs worked yesterday...then I found that it was wrong....I 
believe that I hit the bug#23538 problem...

The scenario is:
After I delete msg....in order to make sure that msg had been deleted...
I scrolled bar up & down.....I found that the msg has not been deleted....
also, I cannot find the msg from Trash folder.

I tried again from the account setup... to ensure for the setup of deleting msg 
setup to trash (I already selected again), but it is still not working....
Any workaround for this bug? Reminding you that this is from Linux, but actually 
the WinNT not works, either.
Sorry, I mean that I hit the bug#23530 problem....
This works for me now.  I even see a UI in the Advanced section of the Account
manager for my Cyrus server with personal namespace set to ".INBOX"...without
editing prefs.js or anything!
zach, have you followed Jeff's direction from above comments "remove/modify"
anything from the prefs.js file?
Used 02-04-08-M14 commercial build on Linux & WinNT
(should use New profile & needed to edit pefs.js file)
It passed if used new profile...thank to Jeff provide workaround.
But there was some issues regarding migrate profile & account setup for Cyrus 
Server...I will investigate that and log bug later!!
Marking as verified!!
Status: RESOLVED → VERIFIED
Whiteboard: [PDT+] → [PDT+]verified fix already
Already logged bug#27002 for IMAP Cyrus migration problems for default
folders.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.