Closed Bug 235908 Opened 16 years ago Closed 13 years ago

Add an option to search full message source

Categories

(Thunderbird :: Mail Window Front End, enhancement)

x86
Windows 2000
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 229142

People

(Reporter: jbauer, Assigned: mscott)

Details

User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

When I filter mail I would like to have the option of the filter searching
through the full message source.  This option does not seem currently available.

Reproducible: Always
Steps to Reproduce:
1. Try filtering by something not fitting the current options
2.
3.
Please give me that option - that would be a major advantage in comparison with
Outlook, where the search is unnecessarily complicated....

If I click on "Search messages", the first option should not be "Subject", but
"Entire message" and I have my one-click search finally there where it needs to be!
I think, I found it: It does not work, if "View/Threads/Unread" for that folder
is set and the searched messages are already read. In this case, it displays the
messages in the search result, but there are blank when double-clicking on them.
If the found messages are unread, then it works. It works for all messages, if I
set "View/Threads/All" on that folder.

I also just found out, that searching in the body does not work for a searched
folder (IMAP online searched is checked). But that may be an already known bug.
Sorry, please discard my comment. Bugzilla tricked me.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
quicksearch and advanced search have options of "entire message" and body in
current nightly builds

confirming, as I've had occasion to want such a feature (feasible is a different
matter)


(In reply to comment #1)
> Please give me that option - that would be a major advantage in comparison with
> Outlook, where the search is unnecessarily complicated....
> 
> If I click on "Search messages", the first option should not be "Subject", but
> "Entire message" and I have my one-click search finally there where it needs
to be!

not gonna happen?  that would be a horrible performance hit


Status: UNCONFIRMED → NEW
Ever confirmed: true
Ok, if that being the default option is not desired - maybe it would be possible to be able to store it as default option for a user if he desires?

I don't really care about how long it takes to search a message in my folder (I do a good pre-filter and there are not too many in a folder), I do care if I find all messages relevant to a topic or name though.

regards,

Martin

(In reply to comment #5)
> quicksearch and advanced search have options of "entire message" and body in
> current nightly builds
> 
> confirming, as I've had occasion to want such a feature (feasible is a different
> matter)
> 
> 
> (In reply to comment #1)
> > Please give me that option - that would be a major advantage in comparison with
> > Outlook, where the search is unnecessarily complicated....
> > 
> > If I click on "Search messages", the first option should not be "Subject", but
> > "Entire message" and I have my one-click search finally there where it needs
> to be!
> 
> not gonna happen?  that would be a horrible performance hit
> 
> 
> 
(In reply to comment #6)
> Ok, if that being the default option is not desired - maybe it would be
> possible to be able to store it as default option for a user if he desires?

Well, quicksearch setting persists, so a preference default is not needed for it. (if for advanced search, write a new bug against TB preferences and make it depend on this bug - but I wouldn't be in favor of a preference)

*** This bug has been marked as a duplicate of 229142 ***
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.