Bookmark folders right click menu problems

RESOLVED DUPLICATE of bug 203183

Status

()

--
minor
RESOLVED DUPLICATE of bug 203183
15 years ago
12 years ago

People

(Reporter: stu-mozilla, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

When I right click on a folder in my bookmarks menu the expected menu appears.
If I then move my house to a diffierent menu (such as Tools) then the right
click menu stays open.
If I then click on the page in the hope to close the menu it STILL stays open.
The only way I have managed to close the menu is by clicking on it.

I also managed to get the Bookmarks folders to become active while the right
click menu is open for another folder, which leads to the right click menu
staying open until you click on it (at which point it does nothing anyway).

I'm not entirely sure about how I managed this, it often doesn't happen when I try.

Reproducible: Always
Steps to Reproduce:
1. Open Firefox, open the bookmarks menu.
2. Right click on one of the folders.
3. Move your mouse back up to the Tools menu (or any other)
4. Click on the web page.
5. Notice how the right click menu stays open until you click on it (or switch
windows and switch back)

Actual Results:  
I had the right click menu open over my page and could not get rid of it.

Expected Results:  
I expected any window/menu that I opened from another menu to be closed when
that menu was closed.

There were also problems with the right click menu being underneath the folders
expanded views and stuff, but this is only because the right click menu stayed
open and then I expanded a folder (which I shouldn't really be able to do).
(Reporter)

Comment 1

15 years ago
Created attachment 142519 [details]
A screenshot of the right click menu beneath an expanded folder.

Comment 2

15 years ago
this is bug 203183
(Reporter)

Comment 3

15 years ago
True, marking as a duplicate.

*** This bug has been marked as a duplicate of 203183 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.