Shortcut key to select whole words with cursor

RESOLVED DUPLICATE of bug 16203

Status

SeaMonkey
General
--
enhancement
RESOLVED DUPLICATE of bug 16203
14 years ago
13 years ago

People

(Reporter: Søren Thing Pedersen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; da-DK; rv:1.6) Gecko/20040113

I often select words on a page in order to e.g. right-click and search for the
word with using a search engine. It would be great if I could press e.g. the Alt
key and the selection would automatically snap-select the whole word(s) even
though I only select a few letters from the word(s).

If I doubleclick on a word it snap-selects the whole word, but as soon as I move
the cursor, the snap effect is deactivated. Maybe the snap effect should stay
activated

Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago
(In reply to comment #0)
> I often select words on a page in order to e.g. right-click and search for the
> word with using a search engine. It would be great if I could press e.g. the Alt
> key and the selection would automatically snap-select the whole word(s) even
> though I only select a few letters from the word(s).

Press F7, that will turn caret-browsing on : you'll see a cursor inside the
webpage. Then you can select words with the arrows keys. To select a word, use
ctrl-left/right (option-left/right on Mac).

> 
> If I doubleclick on a word it snap-selects the whole word, but as soon as I move
> the cursor, the snap effect is deactivated. Maybe the snap effect should stay
> activated

Press the shift key, then the extension will be extended.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 16203 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.