imap always hangs displaying the first message

RESOLVED WORKSFORME

Status

MailNews Core
Networking: IMAP
--
major
RESOLVED WORKSFORME
14 years ago
9 years ago

People

(Reporter: Phil Kernick, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

When reading mail using IMAP, new messages are displayed in the INBOX, but 
double clicking any of them causes a message window to open, but the message 
area is blank.

This bug identically occurs using Mozilla 1.6 on FreeBSD, so it isn't Windows 
specific.

I have discovered a workaround, which is as follows:
- after new mail is received, click on a non-SELECTable folder
- then open the message and everything works as expected

I'm happy to send an IMAP protocol trace to anyone who wants one, but I don't 
particularly want to post it publicly.

Reproducible: Always
Steps to Reproduce:
1. IMAP server is imap-uw-2002d
2. Download mail via IMAP
3. Double click new message

Actual Results:  
Message window opens, but message isn't there.

Expected Results:  
Message should have appeared.

Seems to be related to imap-uw-2002d.
This has been installed as a FreeBSD port.
(Assignee)

Comment 1

14 years ago
sure, send me a log at bienvenu@nventure.com
(Reporter)

Comment 2

14 years ago
Sent imap protocol log.  If you need any more, let me know.
(Reporter)

Comment 3

14 years ago
Here is the tail of a network snoop on an imap session that doesn't display the
message.

As you can see, Mozilla gets the headers, but in response to double-clicking on
the message, it never tries to FETCH the body.


12 list "" "INBOX"
* LIST (\NoInferiors) NIL INBOX
12 OK LIST completed
13 select "INBOX"
* 7 EXISTS
* 2 RECENT
* OK [UIDVALIDITY 1074305261] UID validity status
* OK [UIDNEXT 3596] Predicted next UID
* FLAGS (NonJunk $Forwarded Junk $MDNSent $Label3 $Label1 $Label2 $Label4
$Label5 \Answered \Flagged \Deleted \Draft \Seen)
* OK [PERMANENTFLAGS (NonJunk $Forwarded Junk $MDNSent $Label3 $Label1 $Label2
$Label4 $Label5 \* \Answered \Flagged \Deleted \Draft \Seen)] Permanent flags
* OK [UNSEEN 6] first unseen message in /var/mail/philk
13 OK [READ-WRITE] SELECT completed
14 UID fetch 1:* (FLAGS)
* 1 FETCH (UID 2224 FLAGS (\Seen NonJunk))
* 2 FETCH (UID 2826 FLAGS (\Seen NonJunk))
* 3 FETCH (UID 2853 FLAGS (\Seen NonJunk))
* 4 FETCH (UID 3293 FLAGS (\Seen))
* 5 FETCH (UID 3428 FLAGS (\Seen NonJunk))
* 6 FETCH (UID 3594 FLAGS (\Recent))
* 7 FETCH (UID 3595 FLAGS (\Recent))
14 OK UID FETCH completed
15 UID fetch 3594:3595 (UID RFC822.SIZE FLAGS BODY.PEEK[HEADER.FIELDS (From To
Cc Subject Date Message-ID Priority X-Priority References Newsgroups In-Reply-To
List-ID)])
* 6 FETCH (UID 3594 RFC822.SIZE 2633 FLAGS (\Recent) BODY[HEADER.FIELDS ("FROM"
"TO" "CC" "SUBJECT" "DATE" "MESSAGE-ID" "PRIORITY" "X-PRIORITY" "REFERENCES"
"NEWSGROUPS" "IN-REPLY-TO" "LIST-ID")] {345}
From: SpamCop AutoResponder <spamcop@devnull.spamcop.net>
To: spamcop@kernick.org
Subject: SpamCop has accepted 1 email for processing
Date: Sun, 21 Mar 2004 04:16:03 GMT
Message-ID: <spamid362380121@msgid.spamcop.net>
In-Reply-To: <20040321040854.B6BD674406@mail.rotfl.com.au>
References: <20040321040854.B6BD674406@mail.rotfl.com.au>

)
* 7 FETCH (UID 3595 RFC822.SIZE 428140 FLAGS (\Recent) BODY[HEADER.FIELDS
("FROM" "TO" "CC" "SUBJECT" "DATE" "MESSAGE-ID" "PRIORITY" "X-PRIORITY"
"REFERENCES" "NEWSGROUPS" "IN-REPLY-TO" "LIST-ID")] {250}
From: "00" <MAILER-DAEMON@ynmail.com>
Subject: =?GB2312?B?tdjM+qGix+G57KGiu/CztaGit8m7+qOs0rvCt727zajO3tPH?=
To: philk@rotfl.com.au
Date: Sun, 21 Mar 2004 14:09:18 +0800
X-Priority: 3
Message-Id: <20040321060859.C367E74402@mail.rotfl.com.au>

)
15 OK UID FETCH completed

Product: MailNews → Core
(Reporter)

Comment 4

13 years ago
Problem seems to be resolved in Thunderbird 1.0.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.