"Send Page" should use Fully Qualified Domain Names [FQDN]

RESOLVED FIXED

Status

()

--
enhancement
RESOLVED FIXED
15 years ago
14 years ago

People

(Reporter: miken32, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040217 Firefox/0.8.0+

When DNS is set up to append a suffix to domain names, you can visit a web site
by simply typing, for example, "www" in the address bar.  But if you want to
send a page to someone, the URL "http://www/foo.html" will likely be useless. 
If it's possible (and I don't know if it is, depending on how the OS returns DNS
queries) the FQDN should be included, rather than just the subdomain.

Reproducible: Always
Steps to Reproduce:
1.configure DNS to append a suffix to unknown domain names
2.load a URL
3.use the "Send Page" menu item

Actual Results:  
only the subdomain is included in the sent URL

Expected Results:  
the full domain name should be included in the sent URL

Comment 1

15 years ago
WFM 0.8 WinXP--regression?

Comment 2

15 years ago
Oops, I didn't understand the problem completely, so ignore my WFM.

Comment 3

15 years ago
This is definitely not a bug. However, I suppose it could potentially be an
improvement (not sure if it's implementable). Setting to enhancement.
Severity: normal → enhancement
OS: Windows 2000 → All
Hardware: PC → All
Summary: "Send Page" should use fully qualified domain names → "Send Page" should use Fully Qualified Domain Names [FQDN]
(Reporter)

Comment 4

14 years ago
FF seems to replace the hostname with the FQDN now in the address bar as well as
'Send Page,' so this is no longer an issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.