Can't reply/forward some messages when using multiple identities

RESOLVED EXPIRED

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED EXPIRED
14 years ago
8 years ago

People

(Reporter: Sebastian Delmont, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

When using multiple identities, I can't forward or reply(all) to a message that
was sent to an email not included in those identities. For example, identities
include user@example.com & name@example.net, but the email was sent to
alias@example.com.

The toolbar buttons and context menu options are active, but perform no action.


Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago
I get exactly the same problem.

Comment 2

14 years ago
I just tried it with a .forward.
The message was sent to a user without an identity and the .forward file
forwarded it to a user with an identity.
It worked fine: User-Agent: Mozilla Thunderbird 0.7+ (X11/20040730)

Comment 3

14 years ago
I'm also seeing this (Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.2)
Gecko/20040803).  "Reply", "reply all", "forward", "forward as", and "edit as
new" are all misbehaving as described.

Moving or copying the mail to different folders does not seem to make a
difference, so it must be something about the specific mails when combined with
identities that is failing.

I don't remember this ever happening before upgrading from 1.7.1 to 1.7.2, so my
guess is that something has changed.

Comment 4

14 years ago
Sorry -- should have also mentioned two things:

1) I'm seeing this with Mozilla Mail (having hand-edited configs to incorporate
multiple identities).

2) This is only happening with some mail, but I can't work out why others still
work fine.

Comment 5

13 years ago
I think I'm seeing the same bug in Thunderbird 0.9:
http://62.216.18.38/temp/thunderbird_bug.png

I got an email with a number of attached emails, I opened such an attached email
and now I can't reply.
This bug was filed in February, the fix was checked into CVS in June according
to bug 235762 comment 21.  All comments posted to this bug since June that claim
to reproduce this are either using a different product (Mozilla MailNews rather
than Thunderbird -- and that should have been resolved with the Aviary branch
landing in the last couple weeks) or are seeing a different problem (you can't
reply to or forward an email that's in an attachment, which is by design I believe).


*** This bug has been marked as a duplicate of 235762 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
err...  ignore me, that comment (and resolution) was meant for a different bug,
had my tabs mixed up.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
To all reporters:
Does problem still remain on newer Thunderbird 1.0?

Since nexts are already implemented,
 (1) UI for SMTP choice of multiple identities is already implemented.
     - Go "Manage multiple identities..." of Account Settings,
       then choose SMTP server for each identity.
 (2) Initial SMTP setting of an idenitity is same one for main account.
     - See Bug 272354 Comment #5,
       then define identities again.
I think remaining SMTP choice problem on multiple identities is Bug 272354 only.
See Bug 277998 instead of Bug 272354 for remaining problem.

Comment 10

13 years ago
I can still reproduce this bug. I have two identities 
1) the main one is under "Local folders" 
2) the secondary one is under example.com(pop)

If I receive any mail for example.com I cannot reply to it, irrespective of
whether the to address has an identity or not. If I drag and drop the mail into
Local Folders, I can reply to it.

Comment 11

13 years ago
Sorry for forgetting this but I am running Thunderbird version 1.0 (20041206) on
Windows XP
Multiple identitiy definition isseus are already resolved by next bugs.
 (1) Bug 262300 : Attributes such as FCC folder or SMTP
 (2) Bug 246744 : UI for setting of identity's attributes
 (3) Bug 272354 : SMTP choice of an identity(fixed by fix for Bug 246744)
    (Bug 277998 stil remains. SMTP choice when SMTP choice change on primary)
However, above solution is applied on newly defined identitiy settings only.
So if your identities are defined before fix of above problem, identities
probably don't have proper settings.

Since (2) is already fixed, UI for identity settings are already available.
Check identity's settings first, then change them properly, thru "Account
Settings"/"Manage Identities"/"Edit".
Will problem still remain?
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.