"blah" is not a registered protocol sheet gets stuck on Mac

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
15 years ago
15 years ago

People

(Reporter: dustin, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

This seems to happen with several different sheets.  I'll wait to see what happens with this bug before I 
post others in the same vein.

If you type in an incorrect protocol, the sheet comes down and won't go away when you press "ok"

Reproducible: Always
Steps to Reproduce:
1. Type "abouto:" in the location bar, hit enter
2. Sheet comes down telling you you're fat-fingered
3. Click OK
4. Click OK
5. Click OK
6. ...
Actual Results:  
Nothing

Expected Results:  
The sheet should go away

Comment 1

15 years ago
hmm, WFM same build under 10.3.2. What version of OS X are you running?
(Reporter)

Comment 2

15 years ago
Sigh.  MacOS X 10.1.5.  Whoever at apple decided that upgrades should cost money
(that a grad student doesn't have) needs to be slapped.

Comment 3

15 years ago
I have this same bug. It's very frustrating because the only option is to shut
down firefox once it occurs. I've seen it with the "remember username", "leaving
encrypted page", "basic authentication" and other various sheets. I have not yet
found a way to consistently reproduce it.

Other strangeness which may or may not be related. When the basic authentication
sheet was frozen, I couldn't tab to the password field, I had to explicitly
click on it. Also, I noticed that my bookmark toolbar folder buttons weren't
visible in the toolbar when I opened the browser, the first sheet I came to was
stuck.

MacOS version 10.3.2 build 7D24
Firefox version 0.8, confirmed in the nightly builds as well.

Please fix this for 0.9.
Flags: blocking0.9?

Comment 4

15 years ago
It works for me (no bug), Mac OS X 10.2.8, 20040305 Firefox/0.8.0+

Dustin and Christopher, a few things to try:

- Are you using any browser themes, other than the standard "Mozilla Firebird
Default" that comes with the browser? If so, please use the default theme and
try again.

- Do you have any browser extensions installed? If so, try disabling them.

- Temporarily trash your profile, which is the Phoenix folder in the Library in
your Home folder. Start with a fresh profile and see if that fixes it. If that
works, you can probably rescue your bookmarks file from your old profile and
copy it to your new one.

Please let us know if any of these things fix it.

cheers 

Comment 5

15 years ago
wfm Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b)
Gecko/20040308 Firefox/0.8.0+

mac os 10.3.2

Comment 6

15 years ago
By the way guys, just in case you've tried to reply by email, it won't have gone
through. It's not supposed to be possible anyway, but there's a bug in the mail
daemon that prevents your mail bouncing, so you have no idea it hasn't worked.
If you wanna comment, please just use the website.

If no comments, I'll resolve this as WORKSFORME in a few days.
(Reporter)

Comment 7

15 years ago
(In reply to comment #6)
> By the way guys, just in case you've tried to reply by email, it won't have gone
> through. It's not supposed to be possible anyway, but there's a bug in the mail
> daemon that prevents your mail bouncing, so you have no idea it hasn't worked.
> If you wanna comment, please just use the website.

The mac on which I run X 10.1.5 is at work, and I'm away from work for the week.  So i can't try some of 
the things you suggest.  Can you keep this open for a bit longer (until next week) so I can see if they 
help?

Dustin

Comment 8

15 years ago
No worries :)
(Reporter)

Comment 9

15 years ago
It seems FireFox is having a good day -- I can't get this bug to recur.  The "abouto:" error sheet goes 
away, as do some of the others that have gotten stuck: HTTP auth sheets, SSL cert error sheets, and 
cookie sheets.

I suppose I have no grounds to argue if you close this as WORKSFORME :)

Comment 10

15 years ago
Thanks Dustin. Please let us know if the problem comes back.

Christopher, are you still seeing this bug too? If so, please let us know.
Otherwise I'll resolve this bug as WORKSFORME in a few days.

Comment 11

15 years ago
Wayne,

I have previously tried all of your suggestions. I can reproduce with a clean
install.

I'm guessing it's something about my configuration? What info can I provide?

Comment 12

15 years ago
The only time I can reproduce this bug is if I have the browser open and let the
computer go to sleep (bug 232715) first. As a result of that bug, all dialog
boxes seem to break and won't respond to input.

If that's not the problem with you, and this bug occurs when the browser is
freshly loaded, then I'm not sure what's going on.

Just to double-check, if you go to Preferences:
-Themes only lists "Modern" and "Mozilla Firebird Default"?
-Extensions lists nothing?

If you open Console (in your Utilities folder), does anything pop up in
console.log the minute you see this bug? (It'd be best to clear the log before
you start the browser ;)

Perhaps it's due to a bad plugin, but that'll be a nightmare to go through.
(Reporter)

Comment 13

15 years ago
Bingo.  This is some weird product of a bug in the sleeping code in MacOS
10.1.5.  My mac is acting funny wrt sleeping lately, anyway.  And it has been
restarted.

Anyway, yes, after a sleep I see this phenomenon, so it's a dupe of bug 232715.
 I'll leave the fiddling of the bugzilla settings to you.

Comment 14

15 years ago
Is that the same with you, Christopher? Do you only see this bug after the
computer sleeps while the browser is active? Or all the time?

Comment 15

15 years ago
I can try to see if the sleeping has anything to do with it. But thinking back,
I'd say that it is very likely that the computer slept prior to the behavior.
Also, I see the same problem with the extensions are themes...

Comment 16

15 years ago
Based on above comments, and no further input, marking as WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

15 years ago
Flags: blocking0.9?
You need to log in before you can comment on or make changes to this bug.