If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

In day view event duration is drawn too short if event starts on hour 0

RESOLVED WORKSFORME

Status

Calendar
Sunbird Only
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: Jussi Kukkonen, Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040224 Firefox/0.8.0+

Events starting on the first hour of the day are drawn incorrectly.

The event 'length' is calculated from (the start hour) hour-box heigth.
Calendar.css, however, sets "border-top: none;" for the first hour-box.

The drawing problem is removed if the style setting is removed (and IMHO it
doesn't even look bad).



Reproducible: Always
Steps to Reproduce:
1. create event starting on hour 0 with a length of 10 hours 

Actual Results:  
Event is about10 pixels shorter than it should be.

Expected Results:  
event visual length should be 10 hours
(Reporter)

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

13 years ago
Reporter:
    This works for me now in both Calendar 2005011112 and Sunbird 20050203.  Are
you still having this problem?
(Reporter)

Comment 2

13 years ago
Works for me too.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: gurganbl → sunbird
You need to log in before you can comment on or make changes to this bug.