weezyek.topcities.com - Requires IE version 4 or better

RESOLVED FIXED

Status

RESOLVED FIXED
15 years ago
4 years ago

People

(Reporter: charlesso, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030630

http://weezyek.topcities.com/musicindex.html ,, this site requires IE version 4
or better to open. It will lock you to the page causing you to use xkill or in
windows using MOZILLA 1.6 use " End task " ,, the 3 finger salute. info window
opens locking you to the page

Reproducible: Always
Steps to Reproduce:
1.Go to the web site ,,http://weezyek.topcities.com/musicindex.html
2.
3.

Actual Results:  
Page wont open and page freeze ? 


Expected Results:  
Open the page
-> TE
Assignee: general → english-us
Severity: major → normal
Status: UNCONFIRMED → NEW
Component: Browser-General → English US
Ever confirmed: true
OS: Linux → All
Product: Browser → Tech Evangelism
QA Contact: general → english-us
Hardware: PC → All
Version: Trunk → unspecified
Summary: Requires IE version 4 or better → weezyek.topcities.com - Requires IE version 4 or better
Egads... that is one of the most convoluted uses of Javascript that I've seen. 
In my opinion, things like that ought to be discouraged, if only because of the
*major* accessibility issues of 'encrypting' a site using Javascript.

And why do I put 'encrypting' in quotes?  Because it can easily be *decrypted*
using what Javascript is already there, just by swapping out eval() with
document.write(), lathering, rinsing, and repeating.

Decrypting the script in such a manner shows that it specifically checks for
"Netscape" in the browser string if it's discovered to be a Gecko browser.  It
works in NS6/7, in other words, but not in any other Gecko-based browser.
Created attachment 142816 [details]
The 'decrypted' source of weezye's site

And it's STILL convoluted!
fixed
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.