Closed Bug 236055 Opened 17 years ago Closed 17 years ago

Javascript can disable right click

Categories

(Firefox :: General, defect)

x86
Windows 2000
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 86193

People

(Reporter: mozilla_bugs, Assigned: bugzilla)

References

()

Details

User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040226 Firefox/0.8.0+

http://www.capoeirasj.com/whatis/index.html

On this page there is some javascript that disables the right click menu. Older
versions of firefox/firebird]/phoenix used to not be affected by this kind of
script.

Reproducible: Always
Steps to Reproduce:
1. Right click on http://www.capoeirasj.com/whatis/index.html
Actual Results:  
No menu appears

Expected Results:  
Right click menu to appear

The offending script:

//Disable right click script III- By Renigade (renigade@mediaone.net)
//For full source code, visit http://www.dynamicdrive.com

var message="";
///////////////////////////////////
function clickIE() {if (document.all) {(message);return false;}}
function clickNS(e) {if 
(document.layers||(document.getElementById&&!document.all)) {
if (e.which==2||e.which==3) {(message);return false;}}}
if (document.layers) 
{document.captureEvents(Event.MOUSEDOWN);document.onmousedown=clickNS;}
else{document.onmouseup=clickNS;document.oncontextmenu=clickIE;}

document.oncontextmenu=new Function("return false")

*** This bug has been marked as a duplicate of 86193 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.