Closed Bug 236059 Opened 16 years ago Closed 15 years ago

can't browse samba shares

Categories

(Firefox :: General, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 62851

People

(Reporter: mozilla, Assigned: bugzilla)

Details

User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

At my LAN we have a great webbased share-indexer. In IE (i only keep it around
for this and i know lots of people who totally stick to IE because of this) you
can just click it and the download starts off of the samba-share.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
What happens if you try to go to a samba share?  What is the format you're 
using for the share name? (should be \\host\share) and that should work fine.  
Samba vs. other file shares should be transparent to the application.
QA Contact: mconnor
file://nedservers/Documents/My%20Music/Sample%20Music is one of the links i
click and then nothing happens.

If that's the wrong format and you can change it to something that IE can still
work with i might be able to convince the owner of the site to change it.
With manually rewriting the url to the notation you mention i indeed can get to
the Samba shares. I'd like to get a file-explorer window, so i can start
dragging files, directories, etc. to my desktop or other file-explorers. Now i
can only do it one by one via "Save Target". This would make the function
OS-dependent i guess. I think the same applies to ftp-URLs.
Dupe of bug 62851. Mike: \\netserv\somedir doesn't work in Firefox

*** This bug has been marked as a duplicate of 62851 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
well, it worked for me and the reporter, so you're obviously not reading the bug
that closely.

it does convert to a huge file://///shoehorn/C$/ scheme, but it does work.

now, bug 122022 would have been the right bug to dupe this against, but it
doesn't really matter.  I don't think either have any fix besides evangelism.
My mistake, I tried only \\host, which should also work. Why doesn't that work
but \\host\share work? file://///something on Linux would be a valid path for a
standard disk file. Try file://///usr on Linux, and you'll see what I mean.
Samba browsing is not a Windows-only capability, and the method achieved should
be consistent with what IE and nautilus do, and also consistent across
platforms. We can open a helper application, such as nautilus and explorer. I
mentioned all this in bug 62851. 
based on what? The standard UNC convention has always been \\server\share

If you don't specify a share, what are you connecting to?
The server. Try it in explorer.
You need to log in before you can comment on or make changes to this bug.