Paragraphs do not wrap when Mozilla originated mail viewed in webmail via IE

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: pivonka571, Assigned: sspitzer)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

http://forums.mozillazine.org/viewtopic.php?t=50409

HTML email prepared in Mozilla and it is opened by someone using WEBMAIL and the
IE browser, the paragraphs do not wrap, but continue horizontally and the
horizontal scroll bar must be used. I have not yet determined if this occurs
when the mail is opened in Outlook or Outlook Express, but do not believe it
does, since neither my daughter nor other users using OE and Outlook express
have complained.

The same email is opened and displayed properly (paragraphs wrap to window
width) when the WEBMAIL is accessed via the Mozilla browser.

My sense is that IE is not finding a control it is looking for when it handles
webmail, that would tell it to wrap paragraphs. I know that Mozilla tries to be
standards compliant, while IE is not standards compliant. It is possible that IE
is expecting something that the standard does not require, but a lot of other
possible explanations exist as well.

I suspect that a bug report is needed on this problemm

Mozilla 1.4 build ? 20030624 ?
IE6
Win XP Pro

Reproducible: Always
Steps to Reproduce:
1.  Prepare and send HTML email (including long paragraphs) using Mozilla mail
and news to an address accessible via WEBMAIL
2.  Access the email via webmail using the Mozilla browser, verify that
paragraphs wrap in the read mail window
3.  Access the email via webmail using the IE browser, verify that the
paragraphs are not wrapping, an that the horizontal scroll bar must be used to
read each paragraph.

Actual Results:  
The email accessed via webmail using the IE browser did not display properly. 
The paragraphs did not wrap, and the scroll bar had to be used to read the mail.

Expected Results:  
The long paragraphs in the email should have wrapped, so that scrolling was not
required in order to read the email.

Yeah, I have an old build.  But I am afraid to install the
mozilla-win32-installer.exe listed at the link, as it seems certain that doing
so would cause the loss of all my settinngs, bookmarks, email, and profiles. 
Sorry, but that's just too risky.

Comment 1

15 years ago
Have you examined the source of one of these messages (in your Sent folder) that 
is causing the problem?  If the source text shows an entire paragraph on one 
line without wrapping, then that's arguably a problem with Mozilla, but I don't 
see that symptom in my testing.

Otherwise, the problem is with the browser/service combination and I don't know 
what Mozilla should do to prevent it.


OT:
> Yeah, I have an old build.  But I am afraid to install the
> mozilla-win32-installer.exe listed at the link, as it seems certain that doing
> so would cause the loss of all my settinngs, bookmarks, email, and profiles. 
> Sorry, but that's just too risky.

Your fears are pretty groundless, in my experience.  All the settings, etc. are 
stored in the profile, which is not touched by uninstall/reinstall.  I've 
installed dozens of Moz builds in the past year and they've always come up with 
the right settings.

The only thing to be careful about is to not install one build into the same 
directory where an older build exists; either uninstall the old one first, or 
install the new one into a different directory.

However, I doubt you'll see different behavior on Webmail's part by upgrading to 
a newer Mozilla (or Thunderbird).

Comment 2

15 years ago
No response from reporter; =>WFM

Jim Pavonka, if this bug is still a problem for you and Mozilla is the issue 
(as described in comment 1), feel free to reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

15 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 3

15 years ago
My reopening of this bug report may be premature.  I have just FAILED to
duplicate the bug, accessing Earthlink.net Webmail using the IE browser.  

I have been unable to update my Mozilla from 1.4 to 1.6, due to personal
schedule pressures, so that is not the reason for the change in behavior.  I am
contacting correspondents who have previously reported the issue with paragraphs
wrapping for Mozilla prepared email when accessing Webmail using the IE browser,
to see if the problem has gone away for them too.

It appears that the "WORKS FOR ME" closure of the bug should be reinstated, at
least until current reports of the para wrap failure are received.  If my
correspondents indicate the problem still exists, I will attempt to define it
more precisely, and reopen the bug report at that time.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.