IMAP not refreshing open folder when draft/sent updated because of save draft or msg sent

RESOLVED FIXED

Status

MailNews Core
Networking: IMAP
RESOLVED FIXED
14 years ago
9 years ago

People

(Reporter: mozillastuff, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

When a message is saved to an open folder the folder needs manually refreshed to
see the new message

Reproducible: Always
Steps to Reproduce:
1.connect with imap
2.open drafts
3.create new message save as draft
4. saved message is not visible
5. move to different folder
6. go back to drafts
7. message is visible

- same thing for sending emails / copy to sent when the sent folder is open.
Actual Results:  
folder view not updated

Expected Results:  
folder view updated

worked fine with previous versions.
(Assignee)

Comment 1

14 years ago
the problem is that bringing down the progress window for the save (which we
never really brought up), is cancelling the connection that we try to use to
update the folder.

nsImapMockChannel::Cancel(nsImapMockChannel * const 0x0b8aeab8, unsigned int
0x804b0002) line 8169
nsLoadGroup::Cancel(nsLoadGroup * const 0x0c404518, unsigned int 0x804b0002)
line 377 + 16 bytes
nsDocLoaderImpl::Stop(nsDocLoaderImpl * const 0x0c404450) line 337 + 31 bytes
nsURILoader::Stop(nsURILoader * const 0x0134a610, nsISupports * 0x0c404468) line
831 + 23 bytes
nsDocShell::Stop(nsDocShell * const 0x0c430740, unsigned int 0x00000001) line 2797
nsMsgWindow::StopUrls(nsMsgWindow * const 0x0bc00430) line 395 + 25 bytes
nsMsgProgress::OnStateChange(nsMsgProgress * const 0x0c68c9b8, nsIWebProgress *
0x00000000, nsIRequest * 0x00000000, unsigned int 0x00000010, unsigned int
0x00000000) line 218
nsMsgProgress::CloseProgressDialog(nsMsgProgress * const 0x0c68c9b8, int
0x00000000) line 124
nsMsgComposeSendListener::OnStopCopy(nsMsgComposeSendListener * const
0x0c675178, unsigned int 0x00000000) line 2950
nsMsgComposeAndSend::NotifyListenerOnStopCopy(nsMsgComposeAndSend * const
0x0c68c450, unsigned int 0x00000000) line 3943
CopyListener::OnStopCopy(CopyListener * const 0x0c6257a8, unsigned int
0x00000000) line 156
nsMsgCopyService::ClearRequest(nsCopyRequest * 0x0c625800, unsigned int
0x00000000) line 188
nsMsgCopyService::NotifyCompletion(nsMsgCopyService * const 0x076c03b8,
nsISupports * 0x0c674ac0, nsIMsgFolder * 0x047d0fc4, unsigned int 0x00000000)
line 604
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

14 years ago
Created attachment 143014 [details] [diff] [review]
proposed fix

only stop urls on failed status, don't put up an extra error message in compose
if the user cancelled the fcc.
(Assignee)

Updated

14 years ago
Attachment #143014 - Flags: superreview?(mscott)

Updated

14 years ago
Attachment #143014 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 3

14 years ago
adjusting summary, marking fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Summary: IMAP not refreshing folder → IMAP not refreshing open folder when draft/sent updated because of save draft or msg sent
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.