Closed Bug 236095 Opened 21 years ago Closed 21 years ago

Mail folder with a 1 or 2 letters name shows ghost folders

Categories

(MailNews Core :: Database, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 235272

People

(Reporter: dunkel, Assigned: Bienvenu)

Details

Attachments

(1 file)

User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:) Gecko/20040229

I use to use a mail folder named 'PM' in each of my mail accounts. There I store
Private Mails in various subfolders. As of Build 20040229, each time I start the
MailNews component of Mozilla, not only the PM folder (and its subfolders) is
shown, but also two folder named 'PM.sbd' and 'PM.msf' are shown. I did not
create these folders.

I cannot find another workaround but renaming the folder 'PM' into e.g. 'PMPM'
and restart Mozilla.

Reproducible: Always
Steps to Reproduce:
I assisted someone who has a very similar problem, it's quite clearly due a
regression of recent builds as reverting to 1.6 final corrects the problem for
him (check if it's the same for you), but it's hard to understand what exactly
triggers the phenomen, as many other people don't have anything special in their
mail with the same builds.

How many folders do you use ? In that user's case, it seemed related to using
many subfolders, as he did not have the problem with other profiles that had
less subfolders. Also the mail directory was on a network drive which might
influence too.

The symptom is that many .msf files that should not be there get created inside
the profile directory for mail, like this :
http://www.win-soft.ch/upload/jpg/moz.jpg

After deleting the extraneous .msf files, some get recreated after restarting
Mozilla :
http://www.win-soft.ch/upload/jpg/windir_after_msf_delete.jpg

You should check if you have a similar problem inside your mail directory.
I have reproduction steps.

1. Click on a local folder
2. Create a new folder. Use a short name with only one or two letters.
3. To make the bug more vividly visible, create some more sub-folders inside
that folder with one or two letter names.
4. Close and restart Mozilla

Result :
After restart, all 1 and 2 letter folders now have a ".msf" companion ghost folder.
If the folder has sub-folders, there is a second ".sbd" ghost folder, with the
same sub-folders as the first one.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Mail folder named 'PM' shows ghost folders → Mail folder with a 1 or 2 letters name shows ghost folders
this is a dup of a bug Darin has a fix for (it's in the string code). I'm on
vacation, but I suspect he's checked in a fix, or will soon.

*** This bug has been marked as a duplicate of 235272 ***
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: