Open Bug 236110 Opened 17 years ago Updated 14 years ago

Editor: Midas - relative DIV are immovable

Categories

(Core :: DOM: Editor, defect)

x86
Linux
defect
Not set
normal

Tracking

()

UNCONFIRMED

People

(Reporter: osavill, Unassigned)

Details

User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040218

Inserting a position:relative DIV element in to a designMode="on" IFRAME
(http://www.mozilla.org/editor/midasdemo/) results in an immovable element. This
is the same in IE, so perhaps it is not possible, but it would be extremely nice.

(I have taken the demo code and produced a version that runs in IE and Mozilla
with the minimum of browser dependant code, and that is what I am running these
observations against. Probably someone with a deeper understanding of the
respective DOMs would get even less browser dependant code.)

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Assignee: general → mozeditor
Component: Browser-General → Editor: Core
QA Contact: general → bugzilla
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This problem still exists. 
please, provide detailed steps to reproduce the bug, for example a html fragment to use in http://www.mozilla.org/editor/midasdemo/
Try this:
<div style="border: 1px solid black; position: relative; top: 64px; left: 214px; width: 123px;">Hello</div>
QA Contact: bugzilla → editor
Assignee: mozeditor → nobody
You need to log in before you can comment on or make changes to this bug.