firefox profile 'in use' if hdd is full

RESOLVED INVALID

Status

()

Firefox
General
--
minor
RESOLVED INVALID
14 years ago
12 years ago

People

(Reporter: Zarius, Assigned: Blake Ross)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040228 Firefox/0.8.0+

Whilst working with Firefox, editing files and creating an extension, I found I couldn't start up Firefox... it claimed my profile was in use.  I assumed I'd broken something and went searching, taking about 10-15 minutes (including a consideration of reinstalling Firefox) before I realised my hdd was full.

Tagged this as a minor bug because I can't see it happening too often, however I consider tagging 'normal' since there is no workaround until you realise what's wrong.

Reproducible: Always
Steps to Reproduce:
1. Fill hdd to bursting point (ie cannot create anymore files - even 0kb)
2. Start Firefox
3. When profile manager comes up, select your profile.

Actual Results:  
Alert box: 
Firefox cannot use the profile "Zarius because it is in use.
Please choose another profile or create a new one.

Expected Results:  
Alert box should have informed me that I was out of hdd space.

It assume that since Firefox cannot create "parent.lock" in the profile directory (due to full hdd) it assumes one is there already...
(Reporter)

Comment 1

14 years ago
Created attachment 142714 [details]
Sample of bug.

Comment 2

14 years ago
If Firefox had an option to refuse to start and/or nag about opening
new tabs/windows/downloads if the disk were more than 905 full, I would
enable it. I wouldn't want to be using a web browser normally until I had
created sufficient empty space.

Ben
(Reporter)

Comment 3

14 years ago
I wouldn't want it to refuse to open - if I'm out of (or low on) hdd space, I 
may still had a pressing need to use a web browser before I free up the space.  
A warning may be fine, however I wouldn't set it to 95% or any percent... maybe 
less than 100meg... for example what happens if you have a 170gig partition?  
95% of 170 is is 8.5 gig... that's still ample room :)

Comment 4

14 years ago
I will re-emphasize the points here.

Most filesystems (and I am thinking of the Reiser FS here) don't work
properly if over 85% full are slow if over 92% full and unsafe over 95% full.
Your file system may differ in detail from mine, but I doubt that these
figures are in the wrong ball park.

I fundamentally disagree with your assertion that if a filesystem is over
92% full then there can be something (such as browsing the web) more urgent 
than getting that figure down below 85%. I may accept that a web browser 
need not itself enforce such a policy, but I am only defending my assertion 
that if such a feature were available, I would use it.

Web browsers are heavy and poorly controlled users of disk space owing
to their need for swap, temporary files, cache and downloads. Also users
tend to open large numbers of tabs and windows and/or start large downloads.

My view is that a web browser should either not fail, or should fail
to safe. Since I can't myself think of a suitable pre-allocation policy
that would guarantee never exhausting resources, ensuring soft/graceful/safe
failure would seem the better idea; but that is not to say that I deserve
the last word on this.

Ben.

Comment 5

14 years ago
See bug 228978.

Updated

14 years ago
Depends on: 228978

Comment 6

14 years ago
By all means see also Bug 228978, but that has been noted as not a dup
of this bug.

I suspect that if a fix all disk resource exhausation related probelms
were submitted it would be received favourably; but at the moment it
seems that the developers would prefer to deal with these problems
singly.
This bug was last touched before 1.0.4. Is it still reproducable?
Try the latest branch build (1.0.5): http://www.mozilla.org/products/firefox/
Try the latest nightly trunk build (v1.0+): http://www.mozilla.org/developer
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.