Forum (phpBB) format code do not work on selected text

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: rmhansense, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.4) Gecko/20030624

When composing messages on forum, the html code is entered at the end of the
body of text, vs. around the text.
Example:  
Original text: The last word should be in bold.
Desired text:  The last word should be in <b>bold</b>.
Actual text: The last word should be in bold.<b>



Reproducible: Always
Steps to Reproduce:
1.Compose body of forum content
2.Select and highlight text to be enhanced
3. Click on enhancement feature (Bold, Underline, font, color, etc).


Actual Results:  
Selected text is not enhanced.
Enhancement code is not in correct location.
Only a single code is entered vs. a pair of codes:
The last word should be in bold<b>

Expected Results:  
Selected text should have enhanced codes around it:
The last word should be in <b>bold</b>

This happens on other sites using phpBB forum software.

This occurs with Mozilla 1.4 and 1.7a.
This does not occur with MSIE 6.0, enhancements are done properly.

This problem also occurs with Netscape 4.79, 6.0, 7.1.  Used to use Netscape as
default browser, but had to use MSIE to use those sites.  Recently changed to
Mozilla and am seeing problem again.  Wish to stay with Mozilla vs. MSIE.

Comment 1

15 years ago
I see this on LInux 2004032708
Should this be marked a dupe of Bug 161431?
OS: Windows ME → All
Summary: Forum editing enhancements do not work on selected text → Forum(phpBB) editing enhancements do not work on selected text
Product: Browser → Seamonkey
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 3

13 years ago
worksforme. I believe phpBB folks have fixed this bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Summary: Forum(phpBB) editing enhancements do not work on selected text → Forum (phpBB) format code do not work on selected text
You need to log in before you can comment on or make changes to this bug.