Closed Bug 23622 Opened 20 years ago Closed 20 years ago

Mozilla hangs looking for IMAP-folders

Categories

(MailNews Core :: Networking, defect, P3)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 23312

People

(Reporter: andreas.premstaller, Assigned: mscott)

Details

Builds observed:
nightly 2000011008, and earlier ones
M12 1999122023

Platform: WinNT SP5 (German)
Machine: PII 400MHz, 128MB RAM

On a new installation of Mozilla (deleted mozregistry.dat and Users50-Directory
before) with one mail account on one IMAP server Mozila hangs after entering the
password to access the IMAP directory. The status line says "Looking for
folders...", mozilla.exe is using up all the available CPU-time and after 15
minutes still doesn't show any reaction.
The IMAP directory contains 9 folders, one of them containing subfolders.
If you can tell me how to obtain a kind of IMAP log using only the client
computer I would be glad to provide you some more information.
QA Contact: lchiang → huang
Change QA contact to me. Cc: Lisa.
Andreas, here's how you can turn on imap protocol logging
set NSPR_LOG_FILE=/tmp/imaplog.txt (or wherever you want this file)
set NSPR_LOG_MODULES=IMAP:5

Do you know if you are using a UW Imap server? If so, I wonder if this is
a duplicate of Bug #23312
Here is my .mailboxlist-File:

INBOX
Computer
Main
Sent
Trash
NATWI-News
WWWAdmin
UIBK
Privat/
Privat/Menschen
Privat/Firmen
Privat/SciFi
Privat/Musik

Privat is a folder containing subfolders, previous builds of mozilla were never
able to display any of those subfolders (see bug 15249).

Here is the imaplog-File:

172[19afd30]: mail1.uibk.ac.at:NA:CreateNewLineFromSocket: * OK mail1.uibk.ac.at
IMAP4rev1 v12.258 server ready

172[19afd30]: mail1.uibk.ac.at:NA:SendData: 1 capability

172[19afd30]: mail1.uibk.ac.at:NA:CreateNewLineFromSocket: * CAPABILITY IMAP4
IMAP4REV1 NAMESPACE IDLE SCAN SORT MAILBOX-REFERRALS LOGIN-REFERRALS AUTH=LOGIN
THREAD=ORDEREDSUBJECT

172[19afd30]: mail1.uibk.ac.at:NA:CreateNewLineFromSocket: 1 OK CAPABILITY
completed

172[19afd30]: mail1.uibk.ac.at:NA:SendData: 2 authenticate login

172[19afd30]: mail1.uibk.ac.at:NA:CreateNewLineFromSocket: + ***==

172[19afd30]: mail1.uibk.ac.at:NA:SendData: ***

172[19afd30]: mail1.uibk.ac.at:NA:CreateNewLineFromSocket: + ***

172[19afd30]: mail1.uibk.ac.at:NA:SendData: ***=

172[19afd30]: mail1.uibk.ac.at:NA:CreateNewLineFromSocket: 2 OK AUTHENTICATE
completed

172[19afd30]: mail1.uibk.ac.at:A:SendData: 3 namespace

172[19afd30]: mail1.uibk.ac.at:A:CreateNewLineFromSocket: * NAMESPACE ((""
"/")("#mhinbox" NIL)("#mh/" "/")) (("~" "/")) (("#shared/" "/")("#ftp/"
"/")("#news." ".")("#public/" "/"))

172[19afd30]: mail1.uibk.ac.at:A:CreateNewLineFromSocket: 3 OK NAMESPACE
completed

172[19afd30]: mail1.uibk.ac.at:A:SendData: 4 lsub "" "*"

172[19afd30]: mail1.uibk.ac.at:A:CreateNewLineFromSocket: * LSUB (\NoInferiors)
NIL INBOX

172[19afd30]: mail1.uibk.ac.at:A:CreateNewLineFromSocket: * LSUB () "/" Computer

172[19afd30]: mail1.uibk.ac.at:A:CreateNewLineFromSocket: * LSUB () "/" Main

172[19afd30]: mail1.uibk.ac.at:A:CreateNewLineFromSocket: * LSUB () "/" Sent

172[19afd30]: mail1.uibk.ac.at:A:CreateNewLineFromSocket: * LSUB () "/" Trash

172[19afd30]: mail1.uibk.ac.at:A:CreateNewLineFromSocket: * LSUB () "/"
NATWI-News

172[19afd30]: mail1.uibk.ac.at:A:CreateNewLineFromSocket: * LSUB () "/" WWWAdmin

172[19afd30]: mail1.uibk.ac.at:A:CreateNewLineFromSocket: * LSUB () "/" UIBK

172[19afd30]: mail1.uibk.ac.at:A:CreateNewLineFromSocket: * LSUB () "/" Privat/
I manually removed the Slash from Privat/ in my .mailboxlist and Mozilla
displayed all my folders (and subfolders) beautifully.

I would mark this as a duplicate of Bug #23312 and will post a note to Bug
#15249 as well.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Ok. marking dup of 23312.

*** This bug has been marked as a duplicate of 23312 ***
Status: RESOLVED → VERIFIED
Verified as duplicate.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.