firefox downloads uses 100% CPU usage

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
--
major
RESOLVED WORKSFORME
14 years ago
6 years ago

People

(Reporter: Thomas, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

Downloads using Firefire .8, CPU usage goes to 100% and computer stops untill
download is complete. Had to go back to Firebird 0.6.1 to download.
thanks

Reproducible: Always
Steps to Reproduce:
1.right click on a picture and save image as
2.
3.

Actual Results:  
browser worked just fine

Expected Results:  
downloaded picture without 100% CPU usage

Comment 1

14 years ago
This generally works for me okay. Can you give us a URL (testcase) where you're
having this problem?

Also, if you have virus scanning on, please switch it off and check again.
Often, active on demand virus scanners can cause Firefox to appear to hang for a
bit while they scan downloaded files.
QA Contact: aebrahim
Summary: foxfire downloads uses 100% CPU usage → firefox downloads uses 100% CPU usage

Comment 2

14 years ago
Since the reporter has not responded, and no one else has commented to the
effect that they've seen consisent 100% cpu usage from the download manager
while doing what the reporter says , I'm going to mark this as WORKSFORME.

Reporter (or anyone else), please reopen if you can reproduce.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit

Comment 3

6 years ago
Still an issue in Mac OS X. Camino Version 2.1.2 (1.9.2.28 20120308211433). Long downloads list uses 100% CPU, takes 15-20 seconds on a MacPro to update or move.
You need to log in before you can comment on or make changes to this bug.