xsl:value-of disable-output-escaping ignored in <![CDATA[]]> sections

RESOLVED DUPLICATE of bug 98168

Status

()

Core
XSLT
RESOLVED DUPLICATE of bug 98168
14 years ago
14 years ago

People

(Reporter: Curtis, Assigned: peterv)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

The disable-output-encoding attribute of xsl:value-of appears to be ignored when
using <![CDATA[ sections.  That is, the same result happens no matter what that
value of disable-output-encoding is.

Reproducible: Always
Steps to Reproduce:
1. Create a simple XML file that contains a <![CDATA[ section.
2. Create a simple XSLT stylesheet that applies the value of the CDATA section
in a <xsl:value-of> tag with the attribute disable-output-escaping="yes".
3. Link the stylesheet to the XML file.
4. View it.
Actual Results:  
The text in the CDATA section was escaped (i.e., <, > and & were changed to
entities).

Expected Results:  
The text in the CDATA should not have been escaped when disable-output-escaping
was set to "yes".
(Assignee)

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 98168 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Summary: xsl:value-of disable-output-encoding ignored in <![CDATA[]]> sections → xsl:value-of disable-output-escaping ignored in <![CDATA[]]> sections
(Reporter)

Comment 2

14 years ago
Created attachment 142839 [details]
Simple XML file with CDATA section

Adding simple XML file attachment.
(Reporter)

Comment 3

14 years ago
Created attachment 142840 [details]
Simple XSLT stylesheet to transform XML file

Attaching simple stylesheet.
(Reporter)

Comment 4

14 years ago
Created attachment 142841 [details]
Expected HTML output
You need to log in before you can comment on or make changes to this bug.