``Smooth Scrolling'' makes page navigation more jumpy than does normal navigation without smooth scrolling

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
15 years ago
4 years ago

People

(Reporter: khanreaper, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: bugday0420)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040302
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040302

I have used this same CVS build on a Win32 and Linux machine with smooth
scrolling, and it works perfects; only on OS X does it make page navigation jumpy.

Whenever I scroll across page with [UP], [DOWN] or [MOUSEWHEEL] with smooth
scrolling enabled, the page seems to jump more than it would without smooth
scrolling. Furthermore, it appears as if some content shifts with the scroll
before the remainder of the content shifts--i.e., some of the window draws
asynchronously.

Reproducible: Always
Steps to Reproduce:
1. On OS X (10.2.8), load up any page with content and scroll using [UP], [DOWN]
or [MOUSEWHEEL] with smooth scrolling enabled; note how much the page jumps when
scrolling.
2. Disable smooth scrolling and try procedure one; note how the page still jumps
when it scrolls, tbough to a far lesser degree.


Actual Results:  
1. Page jumps when scrolling; scrolls slowly.
2. Page jumps less than before; scrolls acceptably fast.

Expected Results:  
1. Page to scroll smoothly at the same rate as it would without smooth scrolling.
2. Page to scroll without smooth scrolling at a decent rate.

Updated

15 years ago
Summary: ``Smooth Scrolling'' makes page navigation more jumpy than does normal navigation without smooth scrolling: Only OS X 10.2.8 → ``Smooth Scrolling'' makes page navigation more jumpy than does normal navigation without smooth scrolling

Comment 1

15 years ago
*** Bug 242818 has been marked as a duplicate of this bug. ***

Comment 2

15 years ago
Opps forgot to set as new...
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

15 years ago
This problem also exists in Mac OS X 10.3 (I'm using 10.3.3).  There's also I
know a new API in 10.3 for smooth scrolling.  Perhaps Firefox should just use
this?  It works great with other apps that use it (like Safari).
(Reporter)

Comment 4

15 years ago
While my mentioning of this may not be of much help, I shall do so anyway.
It would appear that Mozilla Camino scrolls smoothly, so perhaps one could
integrate its smooth-scrolling engine into the standard Mozilla tree for Macs.
Product: Browser → Seamonkey

Comment 5

14 years ago
*** Bug 259383 has been marked as a duplicate of this bug. ***

Comment 6

10 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
Moving to Core::XUL. Feel free to reassign or resolve as appropriate.
Assignee: general → nobody
Component: General → XUL
Product: SeaMonkey → Core
QA Contact: general → xptoolkit.widgets
Whiteboard: bugday0420
Version: Trunk → unspecified
I think we can close this as WORKSFORME.
I see pauses when I use smooth scrolling, but navigation isn't jumpy.
Blocks: 100951

Comment 9

4 years ago
WFM in recent FF Mac.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.