Firefox shouldn't steal image file associations

RESOLVED DUPLICATE of bug 216432

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 216432
14 years ago
11 years ago

People

(Reporter: John Myers, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

When I make firefox 0.8 the default browser by Tools->Options->Make Default
Browser->OK, it steals all of my image file associations in Explorer. As I
prefer to manipulate my images with Paint Shop Pro, I do not want my images
opened by Firefox where I can't edit them. 

Also, Firefox is a _web browser_ not an image editor, and as such has no
business stealing my image associations.

Reproducible: Always
Steps to Reproduce:
1.Tools->Options->Make Default Browser->OK
Actual Results:  
All image files were set to open with Firefox.

Expected Results:  
All image file associations should have been left unchanged

-or-

Firefox should have asked me if I wanted to change the file associations.
Please search for bugs and test in a current nightly before reporting bugs.

*** This bug has been marked as a duplicate of 216432 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.