Cancel button on Exit/Exit dialog's Titlebar "WizardMachine" text should change.

VERIFIED DUPLICATE of bug 7717

Status

P3
normal
VERIFIED DUPLICATE of bug 7717
19 years ago
19 years ago

People

(Reporter: bmartin, Assigned: vparthas)

Tracking

other
x86
Windows 98

Details

(Reporter)

Description

19 years ago
Latest NS-CCK build dated: 01-06-00

O/S: Win98

Steps:

1-Launch CCK
2-Select Exit button on any page

Results:

After selecting Exit button, a dialog appears with the titlebar text stating
"WizardMachine."  This text needs to change to something more appropriate.  Any
suggestions Robin, Bij?
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

19 years ago
The Exit button message is a functionality of the wizardmachine and not the
cck wizard. Hence the screen title reads that way.
(Assignee)

Updated

19 years ago
Target Milestone: M14

Comment 2

19 years ago
If we can change the title bar text, I'd recommend changing it to "Netscape
Exit Confirmation".

In addition, I'd like the message text to say the following: "Exit the Client
Customization Kit? All data except for data on the current page will be saved."

Lastly, I'd like to recommend that we add a "Cancel" button to this dialog.
(There may already be a bug filed for this, but I don't know).
(Assignee)

Updated

19 years ago
Target Milestone: M14 → M20
(Assignee)

Comment 3

19 years ago
Currently we are having wizardmachine on the message because we are having a
distinction between the generic wizardmachine and the cck implementation. The
exit message belongs to the wizardmachine because any implementation of it would
require a quit message and the property of the wizardmachine is such that it
saves the values and hence that message.Therefore it would be crossing
boundaries to have neither Netscape(because source is on mozilla) nor
CCK(because it is not supposed to be hardcoded for any one implementation).
  It would require more time and effort in order to be able to trap the exit and
pass messages to it - hence that is ruled out. The one thing that can be done is
perhaps change the message while retaining its generality.
  As regards having a cancel button on the exit - This would again involve
trapping the exit even of the wizard and would require more than available
effort on our behalf (atleast for now)
   Marking this bug as TFM M20
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 4

19 years ago
Actually this is a dup there is already a bug for the cancel button on exit. bug
#7717

*** This bug has been marked as a duplicate of 7717 ***
(Reporter)

Updated

19 years ago
Status: RESOLVED → REOPENED
(Reporter)

Updated

19 years ago
Resolution: DUPLICATE → ---
(Reporter)

Comment 5

19 years ago
This is not a dupe of bug 7717.  This bug is merely requesting a change to the
text in the Exit dialog's title bar from "WizardMachine" to something else.
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → DUPLICATE
Summary: Exit dialog's Titlebar "WizardMachine" text should change. → Cancel button on Exit/Exit dialog's Titlebar "WizardMachine" text should change.
(Assignee)

Comment 6

19 years ago
The titlebar cannot be changed and with reference to the other part of the bug -
viz. the cancel button - it is indeed a dup of the 7717 bug. This bug
unfortunately involved two different parts and like I had explained in my
previous comments the title bar is not changeable and the cancel part is a dup
- hence I am changing the summary of the bug to reflect that.

*** This bug has been marked as a duplicate of 7717 ***

Comment 7

19 years ago
verified dupe 7717 Cancel button should have confirm dialog
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.