setup process uses up all system resources, does nothing

RESOLVED WONTFIX

Status

Core Graveyard
Installer: GRE
--
major
RESOLVED WONTFIX
14 years ago
6 years ago

People

(Reporter: nick, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.0.3705; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

see bug 213252, here http://bugzilla.mozilla.org/show_bug.cgi?id=213252

Reproducible: Always
Steps to Reproduce:
download the latest version of setup, do a clean setup, after all the dialog 
boxes the setup.exe process uses up all system cpu time and does nothing
Actual Results:  
i killed the setup.exe process

Expected Results:  
installed mozilla

see bug 213252 http://bugzilla.mozilla.org/show_bug.cgi?id=213252

Comment 1

14 years ago
please tell what you did try to install, there is no setup.exe for installing
Mozilla.
http://www.mozilla.org/releases/ gives links to 
a Full Installer  (11.8 MB), mozilla-win32-1.7a-installer.exe, 
a Net Installer  (235 KB), mozilla-win32-1.7a-stub-installer.exe
and a Zipfile  (10.6 MB), mozilla-win32-1.7a.zip

Firefox uses a setup.exe, FirefoxSetup-0.8.exe

That are the names of the official release versions for windows, the nightlies
have slightly different names.

Was a mozilla running on this installation, or was it a first-time-install?

Mozilla is using three directories on the machine, one for the profile, another
for the GRE, and the last one for the program.

I would recommend to download the full installer, or the zipfile.
If this is installing well, but can´t connect, you should check the settings.
Help for Autodial under XP:
http://www.holgermetzger.de/efaqgeneral.html#13 (english, short)
http://www.holgermetzger.de/dodxp.html (german, with screenshots)
http://www.mozilla.org/quality/networking/docs/autodial.html

If it doesn´t install, check install_status.log in the GRE folder and the
program folder.
(Reporter)

Comment 2

14 years ago
I downloaded the full setup, mozilla-win32-1.6-installer.exe.  It is a clean
install, no previous versions of mozilla existing.  The "setup.exe" file is
what's unpacked from the "mozilla-win32-1.6-installer.exe" and ultimately ends
up taking up all CPU time and doing nothing until it's killed.  No
"install_status.log" file is ever created, only the mozilla.org\mozilla
subdirectory (empty).

Comment 3

14 years ago
Seems the installer tries to create something like c:\Program Files\Common
Files\mozilla.org\GRE for the Gecko Runtime Environment, but can´t, because that
branch is write-protected, or contains a previous, corrupt installation.

http://www.mozilla.org/projects/embedding/GRE.html#mozTocId115623

Workaround: download and unzip a zip-version, it just creates one folder named
Mozilla, which contains other files and folders, and doesn´t need the GRE.

http://www.mozilla.org/releases/mozilla1.7a/installation.html#win
(Reporter)

Comment 4

14 years ago
I used the .zip file, and everything's running good.  Seems like indeed it's 
something with the installer, could as well be a write-access error somewhere.

Comment 5

14 years ago
changing to -> Installer GRE,  as GRE can´t be installed on your WinXP. 

I assume you don´t have write access to the folder were it should be. Installing
a zip build is only a workaround, as you have to make same settings in the
windows registry to get all plugins working.

See a phoenix link, also valid for zipped Mozilla builds:
http://plugindoc.mozdev.org/phoenix.html

and: http://plugindoc.mozdev.org/important.html
about installing plugins on zipped builds.


So it would be better to log in as admin, or get the write access, and install
an installer build. If the installer succeeds, simply delete the directory
holding the zip build, but you don´t need to.

You can read about the GRE Location/installation in the following bugs:
Bug 190862  	default GRE installation path should be Common Files
Bug 190714  	GRE installation doesn't allow user provided folder/path

Maybe a dupe of this, if you had another GRE installed:
Bug 181325 Second installation can create an essentially empty folder
Assignee: general → gre
Status: UNCONFIRMED → NEW
Component: Installer → Installer: GRE
Ever confirmed: true
Product: Core → Core Graveyard
The GRE installer is long dead
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.