element.body.write() causes Mozilla to just keep loading

RESOLVED DUPLICATE of bug 81980

Status

defect
RESOLVED DUPLICATE of bug 81980
15 years ago
15 years ago

People

(Reporter: osavill, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040301
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040301

If you have an element like an IFRAME :

<iframe id="edit" height="250" width="600"></iframe>

and somewhere, from Java Script, you do something like : 

document.getElementById('edit').contentWindow.document.writeln("<p>Hello</p>");

Mozilla will just keep trying to load something for ever. The "Go to Mozilla
home page" icon keeps right on animating and some links or buttons on the page
become unresponsive. Pressing "Stop loading this page" rectifies the situation.

I have seen this sort of behaviour when writing to the main document. I had
always assumed it was because I was writing at an inapropriate time. The page
goes completely blank, the text then appears and the  "Go to Mozilla home page"
icon goes on animating forever. 

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
That's because the document _is_ loading.

*** This bug has been marked as a duplicate of 81980 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.