automagic float right width and HR doesn't interact well

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
15 years ago
15 years ago

People

(Reporter: grin, Unassigned)

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040122 Debian/1.6-1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040122 Debian/1.6-1

HR causes right floating DIV to have overly huge width with no apparent reason.
See testcase.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

15 years ago
Created attachment 143001 [details]
testcase

All three divs should look similar. It does on Opera for example.
(Reporter)

Comment 2

15 years ago
By the way there could be something similar effect on internet exploder, as I
was told. Can't check, though. 
It looks pretty much the same to me in Opera and Mozilla.

Comment 4

15 years ago
I also see the same widths as in Opera 7.23.
I see nothing wrong with the layout - the overall width of the float is the
result of the left indentation of the UL/LI + the width of the text of the
second list item + the 1em padding on the float itself.

-> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Keywords: testcase
Resolution: --- → INVALID
(Reporter)

Comment 5

15 years ago
Created attachment 143283 [details]
This is how it has been rendered.

I see that maybe you don't see the same output as myself. 

This is version "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040122
Debian/1.6-1", and the attachment shows what I see: first div is 650 px wide,
sevond div is 680 px wide, third one is 220 px wide (approximately). All three
of them should be like the third one: being around 250px wide, since the
longest text is ~190 px wide in the div. I do know that this is caused by the
HR, but still I do not see the reason behind why HR "become" ~580 px wide.

Please either point out a user error or reopen the bug, since the problem do
not seem to be resolved.

Comment 6

15 years ago
OK, I see the problem in Mozilla 1.6 on Linux...
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 7

15 years ago
...but not in Mozilla 1.7a or 2004-03-06-09 trunk Linux

Reporter, try Mozilla 1.7a or newer, thanks.

-> WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

15 years ago
Confirmed, works in v1.7 beta. Thanks.

Updated

15 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.