If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Improved printing dialog

VERIFIED INVALID

Status

()

Core
Printing: Output
P3
enhancement
VERIFIED INVALID
18 years ago
16 years ago

People

(Reporter: Henrik Gemal, Assigned: Viswanath Ramachandran)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
After reviewing Internet Explorers print dialog there are some really nice
features that I would like to see in Mozilla too.
It could be nice if the where some more options/features in the print dialog:
- The ability to how many pages that are going to be printed
- Being able to Collate
- Frames support
- Print table of links
- Print all linked documents

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → REMIND

Comment 1

18 years ago
This is something that the embedding application will look at..
layout printing does not deal with this presently.
(Reporter)

Comment 2

18 years ago
What do you mean with "embedding application"?
dcone, should this bug be reassigned to someone in don melton's XPApps group?

/be

Comment 4

18 years ago
re-opening to assign to browser team as an enhancement.  This bug is really 
about how the browser drives gecko printing.
Severity: normal → enhancement
Status: RESOLVED → REOPENED

Comment 5

18 years ago
unfortunately, component="printing" is overloaded.  This is a browser 
enhancement request.
Assignee: dcone → don
Status: REOPENED → NEW

Comment 6

18 years ago
Yep, all good ideas ...
Summary: Improved printing dialog → [RFE] Improved printing dialog
Target Milestone: M20

Comment 7

18 years ago
Cleared the resolution.  (Bugzilla no longer supports the idea that an open bug
can have any kind of resolution set.)
Resolution: REMIND → ---

Comment 8

18 years ago
Move to "Future" milestone.
Target Milestone: M20 → Future

Comment 9

18 years ago
See iCab or IE 5 on Mac OS for how to implement this, and also bug 42817.

Basically you replace the current `Page Setup ...', `Print ...', and `Print 
Preview' menu items with two items: `Print ...', and `Print As ...'.

`Print ...' opens the standard Windows/Mac/XUL print dialog for printing with the 
default options.

`Print As ...' opens a print preview window, with options for changing margins, 
header/footer, fonts, image display, table of links, etc. The print preview 
dynamically updates as the options are changed. The window includes a
`Page Setup ...' button which opens the OS standard page setup dialog.

One minor correction: number of pages to be printed, and collation, are both 
usually handled by the native print system and the native print dialog, and 
should not be reimplemented (except on X of course).
OS: Windows 98 → All
Hardware: PC → All
More about the Print As model:
http://www.pp.htv.fi/hsivone1/print-ui.html

Comment 11

17 years ago
*** Bug 55708 has been marked as a duplicate of this bug. ***

Comment 12

17 years ago
Also missing in current mozilla is "Portrait/Landscape" selection.

Comment 13

17 years ago
In all of the bug reports relating to printing there seems (naturally) a view 
that the printing setup/preview/prefs functionality is performed via  browser 
dialog boxes.

Can anyone confirm that ALL of the functionality of these boxes will be 
available via javascript for XUL apps developers??

print.outputdevice="laser #1";
print.outputcopies=1;
print.pagecount=1;
print.pagetop=50px;
print.pageleft=50px;
print.portraitmode=true;
print.pageheading="<CENTER>Title</CENTER>;
print.pagefooter="CENTER>Page "+print.pagecount+"</CENTER>;
print.silentmode=true;
print.iframeref=document.getElementById('iframeid');
print.onerror=traperror();
var pid = print.start()
print.cancel(pid);

... and any idea of timeframe??




(Assignee)

Comment 14

17 years ago
Since Don has left, Vishy is taking his bugs in bulk, pending reassignment.
thanks,
	Vishy
Assignee: don → vishy

Comment 15

17 years ago
Do other printing rfes (odd/even pages, portrait/landscape, etc.) depend on 
this bug?

Comment 16

17 years ago
spam : changing qa to sujay (new qa contact for Printing)
QA Contact: shrir → sujay

Comment 17

17 years ago
There are a number of additional enhancements that could be applied to 
printing. Probably should file separate RFEs but don't have time!

 - often, when printing a large document like a paper or a manual, a major 
heading appears at the very bottom of a printed page, and the section begins at 
the very top of the next. This is untidy and difficult to read. You could, of 
course, edit it in composer or something else, but it'd be nice to have an 
option called 'smartprinting' or something, that detects headings or 
subheadings and optionally pushes them onto the next page.

 - conversely, its often necessary to conserve paper for some reason, so an 
option to compress the document to be printed, by removing unnecessary line 
spaces or page breaks and reducing font size, would be useful. 

 - option to display document meta-data (title, description, author, date, last 
updated, next document, prev document, etc.) as a cover page/header/footer with 
the pages to be printed.

 - ability to use document semantic data to automatically contruct table of 
contents. Useful, again, if you're printing a paper or manual, but would rely, 
I imagine, on the author using h1,h2,.. correctly

 - ability to print text selections, rather than the whole document

Anyway, sorry for the long post, but they've been knocking about my head for a 
while.If anyone in authority on these things, thinks any of these are 
worthwhile enhancements, then I'll post an RFE for each. When my exams are 
over....
(Reporter)

Comment 18

17 years ago
"print text selections" is already implemented and working.
(Reporter)

Comment 19

16 years ago
RFE cleanup. RFE is already indicated by the Severity field...Sorry for the 
spam!
Summary: [RFE] Improved printing dialog → Improved printing dialog

Comment 20

16 years ago
We now have the ability to specify how many pages to print and frames support. 
File individual RFEs to printing as necessary.
Status: NEW → RESOLVED
Last Resolved: 18 years ago16 years ago
Resolution: --- → INVALID

Comment 21

16 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.