HTML <!-- Comment --> passing through --> and beyond!

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
15 years ago
11 years ago

People

(Reporter: Miguel Ventura, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040303 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040303 Firefox/0.8

You can notice this 2 tables on the page that get completely commented:

Table 1:
<!-- Inicio do LEFT -------------------------------------------->

<p><br>
<table width="160" class="tabelasemmargens" border="0">

<tr><td><a href="index.html" class="leftMenu">Início</a></td>
<tr><td><a href="docentes.html" class="leftMenu">Corpo Docente</a></td>
...
</table>

<!-- Fim do LEFT -------------------------------------------->

Table 2:
<!-- inicio do footer -------------------------------------------->
<table width="760" class="tabelasemmargens" border="0" height="57">
<tr>
 <td valign="top" width="140" height="53"><img src="images/branco.gif"
width="140" height="15"></td>
 <td width="616" height="53"> 
  <hr>
  <p class="footer">UTL/IST/DEI
    <br>Para mais informações:&nbsp; <a
href="mailto:alberto.silva@inesc-id.pt">alberto.silva@inesc-id.pt</a>
 </td> 
</tr>
</table>
<!-- fim do footer -------------------------------------------->

Well, the view-source window shows everything between those two comments being
eaten and the browser itself shows nothing (where there should be a navigation
window and a small footer). IE seems to display that correcly. That also seems
perfectly "legal" HTML code to me.

It surely has to do with the regular expression that was used to check out the
comments since the number of "-" in the comment-close tag "-->" seems to be
quite relevant. I take 2 and it gets to work. I take other 2 and it gets messed
again.

Reproducible: Always
Steps to Reproduce:
1. Visit the given page.

Actual Results:  
No left menu displayed

Expected Results:  
Left menu should be displayed

Comment 1

15 years ago
It's not valid to put -- into the body of a comment.
http://www.w3.org/TR/html401/intro/sgmltut.html#idx-HTML 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.