All users were logged out of Bugzilla on October 13th, 2018

Status

RESOLVED FIXED
15 years ago
5 years ago

People

(Reporter: dougt, Assigned: dougt)

Tracking

unspecified
Future
x86
Windows XP
Dependency tree / graph

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

15 years ago
Based on my investigation, we will save ~68k by statically linking JS.  lets-do-it!
(Assignee)

Updated

15 years ago
Blocks: 236580
I have no problem with this, but cc'ing bryner, who was working on gcc
visibility hacks to work around ELF PIC inefficiencies.

/be
(Assignee)

Comment 2

15 years ago
you might have problems with my current patch. :-)

Anyone remember the issue wrt why we don't statically link js in mozilla? 
something to do with xpinstall iirc.

Comment 3

15 years ago
Statically link JS to what? the xpinstall stub installer would be fine if we
statically linked JS and XPCOM together into one meta-library (and we could link
NSPR as well).

We'd have to deal with backwards-compatibility crap, since a fair number of
extensions link against libmozjs.so/js3250.dll.
(Assignee)

Comment 4

15 years ago
aren't those extensions part of the bathwater and not the bath?
(Assignee)

Comment 5

15 years ago
err. baby.

Comment 6

15 years ago
well... The JS APIs are technically frozen, as are NSPR. Does that mean we have
frozen the name of the DLL to link against? Darin and I discussed this WRT the
xpcom glue, and my efforts to not have the glue depend on NSPR (I'm almost done
with that patch, BTW).

Comment 7

14 years ago
*** Bug 237575 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

14 years ago
Blocks: 273568
(Assignee)

Updated

13 years ago
Target Milestone: --- → Future
(Assignee)

Comment 8

13 years ago
Created attachment 204564 [details] [diff] [review]
patch v.1
Attachment #204564 - Flags: review?(benjamin)

Comment 9

13 years ago
Comment on attachment 204564 [details] [diff] [review]
patch v.1

OK, this doesn't touch MOZ_JS_LIBS, so if somebody were to accidentally use this in a non-static build all hell would break loose.

So at least I'd like a check after --enable-js-static-build that it is only enabled along with --enable-static.

Something similar to http://lxr.mozilla.org/mozilla/source/configure.in#6174
Attachment #204564 - Flags: review?(benjamin) → review-
(Assignee)

Comment 10

13 years ago
Created attachment 204565 [details] [diff] [review]
patch v.2
Attachment #204564 - Attachment is obsolete: true
Attachment #204565 - Flags: review?(benjamin)

Updated

13 years ago
Attachment #204565 - Flags: review?(benjamin) → review+
(Assignee)

Comment 11

13 years ago
Checking in configure.in;
/cvsroot/mozilla/configure.in,v  <--  configure.in
new revision: 1.1561; previous revision: 1.1560
done
Checking in js/src/Makefile.in;
/cvsroot/mozilla/js/src/Makefile.in,v  <--  Makefile.in
new revision: 3.96; previous revision: 3.95
done
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.