Bookmark Separator Names Don't Appear in Bookmarks Menu

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
--
minor
RESOLVED INVALID
14 years ago
9 years ago

People

(Reporter: Roasted, Unassigned)

Tracking

unspecified
x86
Windows XP
Points:
---
Bug Flags:
blocking0.9 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

When using the Bookmarks Manager, adding a separator to the bookmarks lets the
user give every separator a name to organize the entries inside a folder. This
is a good and easy way of orientation when browsing the bookmarks.
The name is displayed at the left side of the separator, but only in the
Bookmarks Manager. The Bookmarks function in Firefox itself (Menu item
"Bookmarks") lacks the names at all.
Since this function in Bookmark Manger is well designed and a great help I
consider its lack in Firefox a bug.

Reproducible: Always
Steps to Reproduce:
1. Open the Bookmarks Manager
2. Add a new separator and enter a name
3. Return to the Firefox main application, choose the Menu item "Bookmarks" and
navigate to the corresponding separator position

Actual Results:  
The separators name is displayed in the Bookmarks Manager at the left side of
the separator which is what is expected.
But in the Firefox Bookmarks only the separator is shown, without the name.

Expected Results:  
Just like in the Bookmarks Managers display the separator names should be
displayed in the Firefox Bookmarks on the left side of the separator.

Comment 1

14 years ago
Confirming.

To clarify, the separators only don't appear under the Bookmarks menu on the
menu bar.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Bookmark Separator Names don't show up in Firefox Bookmarks → Bookmark Separator Names Don't Appear in Bookmarks Menu

Comment 2

14 years ago
This is the Firefox version of Bug 208017, which depends on Bug 203233.
(Reporter)

Updated

14 years ago
Flags: blocking0.9?
not even close to being a blocker.  At this point, hiding the separator
options/naming seems to be the only thing we'll do in the short term.
Severity: normal → minor
Flags: blocking0.9? → blocking0.9-

Comment 4

14 years ago
why should we hide the naming? it is a useful thing, even if the name isn't
shown in the bookmarks menu. you can use it for orientation in the BM and in the
sidebar it is also shown.
Just let it be...
because functionality that only half-works is a bad thing?  If you put a label
on a separator, and don't use the sidebar for bookmarks, it looks broken in the
main browser window.  Minimizing exposure to the half-working feature is the
minimum of what we should do.

Comment 6

14 years ago
I disagree with the hiding it everywhere plan. The menu is not a tree like the
sidebar and the manager. Those both have quite a bit of additional functionality
not mirrored in the menu. While it would be nice to include seaparator names in
the menu, it's not the kind of glaring UI inconsistency that's going to make
bookmarks less usable for most people. If we can't fix the menu for 1.0, we
should leave the feature in the managers.

Comment 7

13 years ago
*** Bug 275646 has been marked as a duplicate of this bug. ***
*** Bug 305410 has been marked as a duplicate of this bug. ***
*** Bug 329352 has been marked as a duplicate of this bug. ***
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
*** Bug 351615 has been marked as a duplicate of this bug. ***
Assignee: p_ch → nobody
Depends on: 203233

Comment 12

11 years ago
This 'bug' (really an obvious but missing feature) still present (i.e., still missing) in Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0. 

Please allow me to vote, gently, for its repair.

Updated

9 years ago
Duplicate of this bug: 476291
Places at the moment does not support names for separators, thus this is invalid, a new implementation should clearly work toward all bookmarks menus.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.