Closed Bug 236700 Opened 20 years ago Closed 20 years ago

The "v" key brings up the find dialog

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

x86
Linux
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: bzbarsky, Assigned: yuanyi21)

Details

Attachments

(1 file)

With the checkin for bug 229438 (or at least on the same day, and I see no other
reasons this would happen) typing the "v" key brings up the find dialog.  This
makes typeahead-find rather difficult to use.  More to the point, that's not the
behavior that patch was aiming at....
Flags: blocking1.7b?
oh, I'm sorry. Will look into this soon.
Status: NEW → ASSIGNED
This is not caused by xul preprocessor. VK_19 binding for browser is in a
platform specific xul file -
xpfe/browser/resources/content/navigatorOverlay.xul. I didn't use a #ifdef
staff here. 

The original patch (attachment 137978 [details] [diff] [review]) used the correct attrbiute. It is my
mistake to change it during moving the patch.
Comment on attachment 143158 [details] [diff] [review]
I really should use |keycode| instead of |key| for the keybinding

sr=bzbarsky
Attachment #143158 - Flags: superreview+
checked in.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Flags: blocking1.7b?
Component: Keyboard: Navigation → User events and focus handling
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: