Closed Bug 236710 Opened 17 years ago Closed 17 years ago

Saving gzipped tarball to disk unzips, but does not change extention

Categories

(Toolkit :: Downloads API, defect)

x86
Linux
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 235859

People

(Reporter: bradlylane, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8

When saving a gzipped tarball by right-clicking and selecting "Save to Disk" the
browser will unzip the tarball, but does not change the extention from .tar.gz
to .tar - at first, i thought the file was corrupt, but running the command
"file" revealed that *.tar.gz files saved by right-clicking were tar archives,
not gzips.  manually changing the file name made it possibe to open the file.

However, left-clicking on the same file will save it as-is - still gzipped.

Reproducible: Always
Steps to Reproduce:
1. Right-click on a link to a *.tar.gz file
2. Select "Save to Disk"
3. Running gzip, or any gui file archive program, will report the file is not a
valid gzip.
4. Change file name from *.tar.gz to *.tar and open file (for example, in
gnome's file-roller)
Actual Results:  
The file will open.

Expected Results:  
It should not unzip the file.  Or if it does, it should change the extension.

*** This bug has been marked as a duplicate of 233047 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Not a duplicate of bug 233047.  That bug does not deal with right-clicking on
links.  Probably a duplicate of bug 235859, though.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 235859 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago17 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.