The bottom line of a fieldset duplicates

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Jonathan Protzenko, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

When adding dynamically via javascript DOM a new file element to a fieldset, the
bottom line of the fieldset duplicates. The source code that causes the bug can
be found at the specified url.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

14 years ago
Created attachment 143185 [details]
Screenshot of the bug

Comment 2

14 years ago
I see the same problem in recent nightlies of Firefox Mac OS X, and also in Mozilla.

If I click on "Ajouter un champ file", it not only adds a new field, but also a
new line to the bottom of the box. Or rather, it looks like it fails to remove
the old line when expanding the box to accommodate the new fields. If I have
multiple tabs open, and change tabs from, then to, that window, the extraneous
lines have vanished.

Setting Hardware/OS to All/All and Product to Browser.
Status: UNCONFIRMED → NEW
Component: General → Browser-General
Ever confirmed: true
OS: Windows XP → All
Product: Firefox → Browser
Hardware: PC → All
Version: unspecified → Trunk
Created attachment 153866 [details]
Minimal test case displaying the same bug

I've encountered the same rendering bug, when adding or making anything visible
dynamically via scripting, fieldset's borders render incorrectly. It would seem
to me that this is a simple refresh issue, since hiding and redisplaying or
resizing the browser makes the borders render correctly - until the fieldset is
dynamically modified again.
Product: Browser → Seamonkey

Comment 4

13 years ago
Created attachment 168603 [details]
Demonstration of fieldset border bug

I've also encountered this bug; I attached a test case. One workaround I have
found is to set a specific border on the fieldset:

fieldset { border: 1px solid black; }

With the above CSS, the fieldset border is no longer replicated.
This worksforme with a current Linux trunk build... is this still an issue?

Comment 6

13 years ago
Yeah, works for me in the latest Windows trunk nightly (20050201), too. I'll
check the Mac version from home tonight, but certainly appears to be fixed.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 7

13 years ago
Looks good on the Mac nightly too.
You need to log in before you can comment on or make changes to this bug.