Modify PithHelmet or Ad Block so they work with Camino

RESOLVED INVALID

Status

Camino Graveyard
General
--
enhancement
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Mike S., Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US) AppleWebKit/85 (KHTML, like Gecko) OmniWeb/v496
Build Identifier: 

 Besides the often brought up native forms and spellchecking abilities; Camino is lacking a feature 
now present in all other "contender" browsers on Mac OS X. This is the ability to filter images, plug-
ins and advertisements.

 I think the easiest ways to do this would be to either modify Ablock ( http://adblock.mozdev.org ) 
to work with Camino, which I assume would mean "porting" from XUL to Cocoa, or to modify 
PithHelmet ( http://culater.net/software/PithHelmet/PithHelmet.php ) to work with Camino which I 
assume is possible since Camino is a Cocoa app and PithHelmet interfaces with Cocoa apps via 
SIMBL ( http://culater.net/software/SIMBL/SIMBL.php )

 I've contacted the author of PithHelmet and he said he has no issues with such a modification 
should the Camino community want to do the work.

 Both of these products have worked well for me and either would be a fine addition to Camino.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
Fine, but this isn't the right place to file a bug about it. For AdBlock, see
<http://bugzilla.mozdev.org/>. For PithHelmet, ask its' author what he uses.

In the meantime, you can use userContent.css rules to block many ads. See
<http://www.floppymoose.com/>.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

14 years ago
 I contacted the PithHelmet author before filing a "bug" (I used the ehnancement
option designed for feature requests...) and he has no interest in bringing it
over to Camino since he's happy with Safari.

 I've tried the CSS file but it just doesn't work well compared to a proper filter.

 I didn't think of filing the request with Adblock's developers as I figured the
Camino development community were going to be more inclined to take on such a
job since they're the only ones who really have any interest in Camino
(everybody else is focused on FireFox).
You need to log in before you can comment on or make changes to this bug.