Unable to display cvs logs using mozilla

VERIFIED FIXED in M13

Status

()

Core
HTML: Parser
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Scott MacGregor, Assigned: harishd)

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+]fix in hand: landing date on or before 03/01/00, URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
This regression happened sometime between last Thursday and Sunday. I know for
sure that I saw it in Sunday's build and it is still there todya.

Try to view the cvs diffs for a checkin off the bonsaii page. I've included an
example url. But it might just be easier to go to bonsaii, click on someone who
checked something in. Click on the file and then on the version you want to see
the diffs on.

You'll notice that the page does not render correctly. First of all, the version
on the right comes up blank. And the text for the version on the left looks
suspicious.

I'm not sure who to assign this too. Starting off with HTML frames because the
source for the url in question has a frame from the left version and a frame for
the right version.

I'm marking this as dogfood. For the PDT team, here is my reasoning. Dogfood is
an internal developer milestone. The action of looking at logs to see what
people checked in is something all the developers need to be able to do
(especially if they are checking into the tree). Without this ability, I find I
need to go re-install 4.7 just to look at the logs of what someone checked in
and I need to do this at least a couple times a day. =(

Updated

18 years ago
Whiteboard: [PDT+]

Comment 1

18 years ago
PDT+

Updated

18 years ago
Assignee: karnaze → rickg
Component: HTMLFrames → Parser

Comment 2

18 years ago
I think this is parser. Then top frame for bonsai cvs is tables where each row
has the pattern:
    <TD><PRE> foo=bar <TD><PRE> foo=baz
so that neither the TD nor the PRE is closed (for convenience and visual layout
reasons in Nav4.x

If the PRE is closed (or alternatively the TD) then the table is layed out
correctly. Passing to rickg. I'll attach a simple testcase.

Comment 3

18 years ago
Created attachment 4171 [details]
testcase; bonsai cvs diff page with bad tables
(Assignee)

Comment 4

18 years ago
*** Bug 23151 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M13

Comment 5

18 years ago
Fixed in my tree, awaiting a chance to land.

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 6

18 years ago
Fixed by improvements to elementtable. We actually do a much better job now that
navigator ever did.

Comment 7

18 years ago
Fixed in the Jan 20th build.
Status: RESOLVED → VERIFIED

Comment 8

18 years ago
Rick, this one is back :(, backing out the changes you did in htmlparser/src on
02/25/2000 22:14 makes this work again.

Reopening and nominating for beta1 (was PDT+ before reopening).
Status: VERIFIED → REOPENED
Keywords: beta1
Resolution: FIXED → ---
(Assignee)

Updated

18 years ago
Assignee: rickg → harishd
Status: REOPENED → NEW
(Assignee)

Comment 9

18 years ago
Let me take this since Rickg has one more PDT+ to work on.

Comment 10

18 years ago
Moving [DOGFOOD] in Summary to 'dogfood' in Keywords.
Keywords: dogfood
Summary: [DOGFOOD] Unable to display cvs logs using mozilla → Unable to display cvs logs using mozilla
(Assignee)

Updated

18 years ago
Whiteboard: [PDT+] → [PDT+] landing date on or before 03/01/00
(Assignee)

Comment 11

18 years ago
Created attachment 5962 [details]
Attaching a patch.
(Assignee)

Comment 12

18 years ago
1. Fix in hand ( see attached patch ).
2. Precheckin    - PASS.
3. Top 100       - PASS.
4. Code reviewer - Rickg.

Comment 13

18 years ago
*** Bug 29619 has been marked as a duplicate of this bug. ***

Comment 14

18 years ago
This would be a bad (embarassing bug) to have to later. When do we think we can
complete the review and land?  Time is growing short.
Whiteboard: [PDT+] landing date on or before 03/01/00 → [PDT+]fix in hand: landing date on or before 03/01/00
(Assignee)

Comment 15

18 years ago
jar, all I need is an approval for checkin.  
(Assignee)

Comment 16

18 years ago
My 2000-03-01 15:55 comments imply that I've a fix ready and that the fix has 
been reviewed and tested throughly.
(Assignee)

Comment 17

18 years ago
PRE was a parent of TD (!).  FIXED now.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 18

18 years ago
With the March 03 build (2000030308), this problem is fixed.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.