find selection not working

VERIFIED DUPLICATE of bug 25096

Status

()

Core
Editor
P4
normal
VERIFIED DUPLICATE of bug 25096
18 years ago
17 years ago

People

(Reporter: sujay, Assigned: David Hyatt)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: no clue how to fix this)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
using 1/11 build of mozilla build = 2000011108

1) launch mozilla
2) launch editor
3) enter some text "lghlg"
4) EDit | Find

look for "gh" and hit OK.

it doesn't highlight "gh" ubntil you dismiss the Find dialog.

Bijal, you mentioned Find not working, I think this is the behavior you're
refering to.

all platforms.

Comment 1

18 years ago
This sounds like a dup of 11425, which was fixed long ago. Perhaps it should be
reopened?

Updated

18 years ago
Assignee: sfraser → saari

Comment 2

18 years ago
It does seem to be a dup, however, I am assigning this to Chris so he can make
the call

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M14

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 3

18 years ago
You're missing one cruital step; click at the beginning of the text before
pressing find or click the "wrap" checkbox in the Find dialog. Both of them
work fine for me. Marking invalid.
(Reporter)

Updated

18 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 4

18 years ago
I have spent several minutes testing this...And it is still not working properly
as described in my bug report.

you don't see the highlighted text until you dimiss the find dialog...this is
not the way its supposed to work.

Comment 5

18 years ago
On what platform? I tried it with Windows NT with a tree from last night and it
works fine.
(Reporter)

Comment 6

18 years ago
Win 98. even If I try your suggestion(click at beginning of doc) it still
doesn't work.

Updated

18 years ago
Depends on: 24443
Resolution: INVALID → ---

Comment 7

18 years ago
We need the selection to render in background windows. Dependent on that bug.

Comment 8

18 years ago
Uh, right, it does work fine on Mac too.

Comment 9

18 years ago
I tested this on win98, and this is what I found:
1. opened apprunner -- build 1999012009
2. selected the test file (will attach the test file next)
3. selected File|Edit Page
4. selected Find from the toolbar, the Find dialog was displayed
5. entered the word "hill" and selected Find

visual feedback: there was no visual feedback in the file

6. selected "Cancel"

visual feedback: the word hill, in the 2nd para was then highlighted

I will also test on win95

Comment 10

18 years ago
Created attachment 4398 [details]
test file for the find operation

Comment 11

18 years ago
tested on win95 using the 200001208 build -- which by the way is the correct
build number for the win98 test (where on earth I got the build number I entered
in my previous comment is beyond me)

Comment 12

18 years ago
I'm having a bad day -- what I wanted to say is,I got the same results on win95
as I did on win98.

Updated

18 years ago
Keywords: beta1
Priority: P3 → P4
Whiteboard: no clue how to fix this

Comment 13

18 years ago
Hyatt said he'd take this since he develops on Win98. 
Assignee: saari → hyatt
Status: REOPENED → NEW
(Assignee)

Comment 14

18 years ago
Using Win98, this works fine for me in a 1/24 build on two different Win98 
machines.

Note there is an initial focus problem, i.e., you need to get focus into the 
frame first, but that's covered by other focus bugs.

I'm marking WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 15

18 years ago
nope...still not working in 1/26 build. I do not see the focus until I dismiss
the dialog...this has nothing to do with your comment: 

"Note there is an initial focus problem, i.e., you need to get focus into the 
frame first, but that's covered by other focus bugs."

Status: RESOLVED → REOPENED
(Assignee)

Comment 16

18 years ago
Well, it obviously only happens some of the time on Win98, because I tried it 
again, and it works just fine for me.

Pushing off.


Status: REOPENED → ASSIGNED
Target Milestone: M14 → M16

Comment 17

18 years ago
It seems like we need some more details here. Please don't randomly ping-pong 

this bug between open and worksforme.



sujay, it might be a good idea to test some different 98 machines, or change 

system settings. please try to find out why we are seeing different behaviour on 

different machines (if indeed we are)

Target Milestone: M16 → M14

Comment 18

18 years ago
Ok, i filed another, more descriptive bug, 25096


*** This bug has been marked as a duplicate of 25096 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: WORKSFORME → DUPLICATE
(Reporter)

Comment 19

18 years ago
thanks Simon! verified in 1/26 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.