http://localhost is not recognized as 127.0.0.1 without a webserver running on local machine.

RESOLVED DUPLICATE of bug 178123

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 178123
15 years ago
13 years ago

People

(Reporter: Jorn van Veelen, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

If there isnt a webserver running on the local machine, firefox directly takes
the first google.com result (in this case: www.localhost.net.au/. an anoying
ad-site) and displays it. Instead of giving the same error-msg as filling in
http://127.0.0.1.
However, when running a webserver, everything goes fine.

Reproducible: Always
Steps to Reproduce:
1. fill in localhost eg. http://localhost
2. press 'enter'
3.

Actual Results:  
Firefox directly takes the first google.com result (in this case:
www.localhost.net.au/. an anoying ad-site) and displays it.

Expected Results:  
Give the same error-msg as filling in http://127.0.0.1.

do not run a webserver on the local machine

Comment 1

15 years ago
reporter, always test with nightly builds before submitting a bug or search
bugzilla, this has already been fixed.

*** This bug has been marked as a duplicate of 178123 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

13 years ago
V/dupe.
QA Contact: benc
You need to log in before you can comment on or make changes to this bug.